[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] ISP programming question

From: David Conger
Subject: Re: [Paparazzi-devel] ISP programming question
Date: Fri, 02 Nov 2012 10:04:30 -0700

I have an update. 

Even with P0.14 low exactly per the Wiki still I am unable to:
1) ISP program a new program
2) re-upload the usb bootldr code a 2nd time

This is actually something I see all the time. On a Tiny.211 I would have to also pull the PGS reset pin low as well as P0.14 to upload the bootldr code a 2nd time. On a Umarim and now NavGo I have never tried a second time to upload the lpcbootldr code. In this case I'm not surprised it's not re-uploading even with P0.14 low (to see how I wired it just go to the bottom of the Wiki and see the image/diagram). 

I'm curious what other pin to hold low or should I try P0.14 at the processor? I will keep trying. However that was my test when ISP programming failed again even with P0.14 low was to try the bootldr which worked the first time (without pulling P0.14 low). Again completely normal for a Umarim and even now NavGoV3 to do the first program without pulling P0.14 low. 

Any thoughts why this behavior? How to enable ISP programming? 

-David Conger
On Nov 2, 2012, at 9:56 AM, David Conger wrote:


On the Ubuntu VM the lpc21isp was found but other errors came. I'm following the WIki exactly from this page:

It has been a very long time since I did this. Some things on the Wiki are likely assumed. Here's what I mean:
1. which UART? I'm going to assume the same one the XBee would use UART1 (same one lpc usb bootldr was uploaded from)
2. On the Wiki there is no mention of P0.14 having to be pulled low to enable the ISP mode. I will add it after verifying this in a few minutes. 

My initial attempt without pulling P0.14 low failed with "no answer on '?'" but I suspect that is expected. 

I suppose this is going to help many because as I read other ways to program they are not complete steps only generally how it's done. I mean someone could not literally follow step by step and be successful without extra information that's assumed the person would know. 

I'm curious, how would someone program over ISP using an XBee? More specific how would you pull P0.14 low remotely? 

On Nov 2, 2012, at 8:01 AM, David Conger wrote:

Hi Felix,

Such a simple answer. I like simple. I will try again on my Linux VM. 

If only it had said command not found vs file not found I would have figured that out.

Thank you. 

-David Conger
On Nov 2, 2012, at 3:58 AM, Felix Ruess wrote:

Hi David,

Well, do you have lpc21isp installed?
It is not distributed with the paparazzi source code....

On debian/ubuntu this is provided by the lpc21isp package.
Looks like you are using OSX though... not sure if it's available there.

Cheers, Felix

On Fri, Nov 2, 2012 at 4:32 AM, PPZUAV <address@hidden> wrote:

I am trying to program a NavGoV3 with ISP programming. I use this command:
lpc21isp   /Users/bmw330i/paparazzi-software/var/NAVGOv3/ap/ap.hex /dev/ttyS0 38400 12000
make[1]: lpc21isp: No such file or directory
make[1]: *** [upload] Error 1
make: *** [ap.upload] Error 2

lpc21isp not found?

My version:
quadzilla:paparazzi-software bmw330i$ ./paparazzi_version

Is it no longer possible to program via serial over UART?

-David Conger
Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]