[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] input2ivy and joystick problem PARTIALY SOLVED

From: Felix Ruess
Subject: Re: [Paparazzi-devel] input2ivy and joystick problem PARTIALY SOLVED
Date: Mon, 10 Jun 2013 16:32:42 +0200

Hi Chris,

since something around v4.2 the joystick is read via SDL for platform independence, meaning that you specify the device index (usually 0, which is the default) and not the device path anymore.

It also seems that in SDL the pov hat is not read as axes, but as an explicit hat type with up/down/.. values.

I tried to quickly write something to read the hat position, see my input2ivy_hat branch.
See also

Cheers, Felix

On Mon, Jun 10, 2013 at 8:25 AM, hendrixgr . <address@hidden> wrote:
I found the problem.
It looks like the -d option is not needed any more, it works without it but:
The test_stick utility report the joystick as "found saitec etc... on SDL device "0"
with only 4 axes when previously all 6 axes where recognised....
Maybe it is an UBUNTU 12.04 problem i don't know but now i have to choose between no throttle or no HUT

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]