[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] paparazzi Lisa/M v2 magnetometer not working?

From: Gautier Hattenberger
Subject: Re: [Paparazzi-devel] paparazzi Lisa/M v2 magnetometer not working?
Date: Fri, 04 Jul 2014 14:02:42 +0200
User-agent: Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

We had a similar problem using directly the hmc5883 (not through the mpu like aspirin). It seems that if you configure the reading mode (to continious mode) before the first initial reading of the sensor (which occurs after 1.3s in the worst case), the configuration is reset to 0 (one shot mode). This problem is solved for all IMU using the general hmc58xx driver (in sw/airborne/peripherals) but I think it is not the case of the aspirin V2.1 which is controlling the mag as a slave of the mpu (sw/airborne/subsystems/imu/imu_aspirin_2_spi.c), so not using the direct driver. I suggest to add a delay before the configuration of the mag, I think this will solve your problem.


Le 04/07/2014 12:34, oberthold a écrit :
address@hidden writes:

I have a paparazzi Lisa/M v2.0 (W/ Aspirin V2.1) which I am having
troubles getting the magnetometer working properly.

What I am doing to test & try getting it all worked out is via the
telemetry link I have set up via an xbee modem, and using the GCS
(ground control station) to change the flight mode to raw_sensors, the
monitor the responses in the "messages" window.

So the gyroscope works great, as does the accelerometer (which I
calibrated and put the results in my airframe file) but the magnetometer
DOES have values for it, but they never change, no matter how I orient
the craft  (quadcopter) [X configuration] do the values change.
HOWEVER, what is weird is that whenever the Lisa/M is power-cycled, then
switched back into raw_sensors mode, the values are different.  So it's
like they work....  but don't update.

Any clue what could be wrong?
just adding to this: i seem to have the exact same problem, only i
wasn't describing it as verbosely [1]. so setting telemetry to
raw_sensors and observing the ACC/GYRO/MAG values the former two are ok
but MAG values don't change (in about 8 out of 10 power
cycles, lisa/m v2, aspirin v2.2, current master).

bst, opt


Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]