[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Telemetry not starting.

From: Wolfgang Schaeper
Subject: Re: [Paparazzi-devel] Telemetry not starting.
Date: Wed, 16 Jul 2014 11:27:26 +0200

Hi Helge,


I am struggling with exactly the same problem with my 2.4 GHz Xbee Pro Series 2 on Tiny 2.1.1 with PPRZ V5.1.1 on Ubuntu 13.10.

Communication starts scarcely, in many cases only after compilation and flashing, but afterwards never again.

I have two sets of Xbees. Both behave the same way.

The problem does not occur when I run my old PPRZ from the Xmas 2008 CD-ROM on the same hardware with the same Xbee configurations.


Did you find a fix?

I can't believe that the extra capacitor helps, because the links runs with the old PPRZ.


Thanks for help,





Von: address@hidden [mailto:address@hidden Im Auftrag von Joseph Muhlhausen
Gesendet: Freitag, 30. August 2013 13:30
An: address@hidden
Betreff: Re: [Paparazzi-devel] Telemetry not starting.


I had a similar issue with a 868LP. I think it was a current spike in my case, I solved it with a 470 uF capacitor between VCC and GND on the xbee connected to the autopilot.



On Wed, Aug 28, 2013 at 11:36 PM, Helge Walle <address@hidden> wrote:

Hi all,


I am having trouble with my telemetry. It seems not to be connected to Paparazzi releases. I have experienced this both on v4.2 and v5.0. Currently I am using v5.0 on a PC with Ubuntu 12.04 LTS.


When I execute GCS and power up the TWOG, then more often than not, the telemetry does not start, and GCS does not get populated. I may have to retry several times before communication initiates. Retrying means stopping/starting GCS and Paparazzi Center, powering the TWOG on/off,  or restarting the PC in various orders. Also plugging the ground modem out/in.


dmesg shows that the level converter is detected by the PC.


When powering the TWOG, after it and the Sparkfun SEN-10121 IMU has initialized, there is a tiny twitch from the servos. Then the RSSI led on the Sparkfun breakout board lights up for approx. 1 second, then nothing more happens. This is when communication fails.


If communication starts, I can see one brief  blink on one of the tx/rx leds, and then after a second or so, the leds start flashing alternately. In this case it is reliable, range is good, and I have not had any modem glitches in flight.


The modems are 2.4GHz XBee PRO series 2. In the plane I have soldered the pins on the modem directly to the wires from the TWOG.


Any idea on what could cause this and where to search? Also, is it the ground station or the autopilot that initiates communication?

Thanks for your help,


Paparazzi-devel mailing list


reply via email to

[Prev in Thread] Current Thread [Next in Thread]