[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] error when uploading code to ppz

From: Sergey Krukowski
Subject: Re: [Paparazzi-devel] error when uploading code to ppz
Date: Mon, 11 Aug 2014 22:18:30 +0200
User-agent: Opera Mail/11.61 (Win32)

Hi Eduardo!

The problem is that for some reason the usb_dfu firmware doesn't work proper with all usb chipsets. I tried once to debug it on one of my laptops with the same problem - something goes very wrong in dfu/usb algorithm.
I reported the problem on developers list, but there wasn't any help.
I found the only solution - trying other laptop (or using external usb controller on it, for example as ExpressCard). Looks like guys there, who use F4 controllers, switching to the internal bootloader and dfu-util, which should work better. If you send me a photo of your KroozSD's downside, I'll probably can tell you ho to switch to internal bootloader and use dfu-util.

Best Regards,

When i try to upload the firmware to krooz board using bootloader i get this error:

sometime the upload process finish but the board not initialize.
Sometime the uoload finished but i get some crazy behaviour in flight.

for now i tried more than 20 times and the process cannot finish.

If i try in my very old laptop it work ok.

when i try in one of my 3 new laptops it fail.

any idea ?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]