[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Lisa/MX 2.1 Bind Button issues

From: Piotr Esden-Tempski
Subject: Re: [Paparazzi-devel] Lisa/MX 2.1 Bind Button issues
Date: Wed, 27 Aug 2014 14:02:31 -0700


Also as there are no dedicated board files for Lisa/MX 2.1 part of paparazzi 
yet. I assume you are still using the ADC1 pin method to induce binding, and 
the button is currently not influencing anything. I am working on board files 
that will take the button into account.

Regarding the Spektrum satellites binding on power up. I am getting the same 
behavior as you do on my Lisa/MX V2.1. I am working on finding out why 
satellites think they should be in bind mode.

Temporarily you can try to do the following:

- Unplug the Spektrum satellites
- Power up the Lisa/MX
- Plug in the satellites

This way the satellites should not go into bind mode on startup and you should 
be good to go. It is not ideal, so I am working on a solution to this problem. 
I will keep you posted on my progress.


On Aug 27, 2014, at 13:49, Felix Ruess <address@hidden> wrote:

> Hi,
> we have an open issue regarding spektrum binding on F4 boards: 
> But what you describe seems like a separate issue (entering bind mode on 
> every startup), feel free to open an issue for this.
> Sounds a bit like as if the internal pullup is not yet active (or too slow) 
> when the bind button is read at startup...
> Although I wasn't able to reproduce this issue with my Lisa/MX v2.0 (without 
> bind button, still using the ADC1 pin).
> Cheers, Felix
> On Wed, Aug 27, 2014 at 10:02 PM, cxiao <address@hidden> wrote:
> Hi all,
> We are using the new Lisa/MX v2.1 boards from 1BitSquared and are having
> issues while trying to bind. On this board, there is a Bind button that
> replaces the previous method of shorting GND to ADC1 on the ANALOG1 port.
> We have followed the instructions on the wiki for  binding the Lisa/M
> <>   using the bind
> button. We are able to bind just fine with this method; however, the Lisa
> does not stay bound when it is power cycled. We have to rebind every time
> the Lisa is turned off and on.
> We think that this is because the Lisa is always in its bind mode
> (regardless of whether the button is pressed or not) - we actually tried
> binding without pressing the bind button at all, and that works.
> We're using 2 OrangeRX R110x satellite receivers. (we've tried with spektrum
> satellite receivers as well, though).
> Can anyone shed some light on this issue?
> --
> View this message in context: 
> Sent from the paparazzi-devel mailing list archive at
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]