[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] AR.Drone 2 magnetometer issues?

From: Ori Pessach
Subject: Re: [Paparazzi-devel] AR.Drone 2 magnetometer issues?
Date: Fri, 30 Jan 2015 15:08:05 -0700

I'm using 5.4, I'm not sure about the filter, and I've seen mag values that appear very wrong (the drone is rotated on the map) even immediately after I boot the drone. I'll have to check the logs from the last couple of times I took the drone out to know about the raw values.

I'm considering just trying to attach a 3rd party magnetometer to the drone using an arduino, or something like that, and patching paparazzi in order to get something working...

On Fri, Jan 30, 2015 at 2:53 PM, Gautier Hattenberger <address@hidden> wrote:
From my experience, ARDrone2 mag are really crappy, and they can fail at any time.
If you run a recent version (v5.4 or master), you *should* have a IMU_LOST indicator in the GCS strip when it occurs (in place of the GPS status).
We have tried to implement something to restart the navboard, but it is very difficult to test since the crashes are unpredictable. It has run for hours on my desk without issues, same for TUDelft guys, but maybe it is still not perfect.
What is your paparazzi version ? which filter are you using ? are the raw mag values still changing when it starts to go wrong ?


Le 30/01/2015 22:29, Ori Pessach a écrit :
So, any ideas from anybody? I'm considering getting a new nav board, but they're not terribly cheap so I thought I'd try to figure out whether the one I have is broken, or whether they're all like that.



On Sun, Jan 25, 2015 at 7:14 PM, Ori Pessach <address@hidden> wrote:

I was wondering if someone who had some experience flying the AR.Drone 2 could tell me whether what I'm seeing is typical, or a sign of a possible hardware issue.

The magnetometer readings seem to be very erratic. I've seen a range of behaviors:

* Tracking the drone's direction perfectly.
* Showing a direction that's rotated 180 degrees
* Showing a direction that's rotated 90 degrees counterclockwise (???)
* Being JUST a little bit off, and then appearing to be perfectly fine after I took the drone and walked around in circles while holding it. 

So, what's going on? I've been seeing some serious navigation issues, and I'm wondering if the magnetometer can get out of calibration midflight, which might explain the erratic behavior I've been seeing: Taking off perfectly, holding position fine, and then navigating to the first waypoint and staying there without issues. Things after that can be pretty erratic, however, including going way off course on the way to the next waypoint, wobbling wildly back and forth, and sometimes trying to fly into the ground at high speed at a 45 degree angle. Which fails, because of immutable physical properties the ground happens to possess. 

I've calibrated the magnetometer, changed the values for the local magnetic field, and the fact that SOME things work, at least at first, would indicate that the drone should be able to fly fine - at least as far as I understand it. 

So... What now? 


Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]