[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] No telemetry

From: Sergey Krukowski
Subject: Re: [Paparazzi-devel] No telemetry
Date: Fri, 24 Jul 2015 08:42:54 +0200
User-agent: Opera Mail/11.61 (Win32)

Actually when the ap board transmit the data to the xbee and the second xbee is paired with the first one, the pprz data flow is to see in the terminal window of the second one. If there are no symbols coming in terminal, but the boards are paired, it should mean that smth wrong with the ap board to xbee connection. Either send the board nothing over the particular uart (problems with setup) or some problem with wiring, for example mixed up rx and tx wires.

In XCTU I can "Discover radio nodes in the same network" and the 'Flyer' (i.e. the NI of my S1) is visible. The result is absolutely equivalent to what I see when I connect the S1 to another laptop and use the XCTU console to successfully receive and transmit messages. By 'when the board is powered' I mean when a usb is plugged in and the green LED is steadily alight.

---- On Thu, 23 Jul 2015 13:33:40 -0700 Sergey Krukowski <address@hidden> wrote ----

Hi Evgeni!
What do you actually mean under "when the board is powered I start XCTU
and can detect the S1"?
Do you see the data flow in the xctu terminal?
> Hi all,
> I can't get my Lisa/Mv2.0 to communicate with the GCS installed on
> Ubuntu 14.04.
> My configuration:
> LisaM with Aspirin 2.2 from 1 bit 2, connected via a DRX R615X receiver
> to a DX4e transmitter @ UART2, and via a Xbee Pro S1 and an Xbee Pro
> 802.15.4 usb adapter to my laptop.
> What I tried:
> 1. Checked the connection between the Lisa and the Xbee. UART2: Rx ->
> DOUT; Tx -> DIN; +3V3 -> VCC; GND -> GND;
> 2. Checked the configuration of the Xbee-s. Baudrates=57600 and PAN IDs
> are set, communication was fine between two laptops with XCTU. Also,
> when the board is powered I start XCTU and can detect the S1.
> 3. Checked the configuration of the airframe file:
> <!-- Communication -->
> <subsystem name="telemetry" type="transparent">
> <configure name="MODEM_BAUD" value="B57600"/>
> <configure name="MODEM_PORT" value="UART2"/>
> </subsystem>
> I get no errors when running the Data link program (-d /dev/ttyUSB0 -s
> 57600) or the gcs. I do get a 'Fatal error: exception
> Xml.File_not_found("~/./paparazzi/conf/modules/nav_survey_rectangle_rotorcraft.xml")'
> when I run the Server though.
> Other (probably un)related problems:
> - The BATT/BIND port of the R615X is connected to UART1 and the
> bind procedure from
> The transmitter > and receiver are binded (the LED turns on when I power up the receiver) > but the servos connected don't move. I suspect the reason might be in
> settings, but can't verify because no telemetry.
> - When I try to browse for a different file I get the following
> error: Selected file '~/paparazzi/conf/airframes/...' should be in
> ~/./paparazzi/conf/airframes/...'. I did set the ENV variables to my ppz > folder. There is a workaround, but I guess it might be related to the
> Server error.
> I am open to any suggestions, since I've checked multiple times
> everywhere I could think to check.
> Thanks!
Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]