[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] No telemetry

From: Felix Ruess
Subject: Re: [Paparazzi-devel] No telemetry
Date: Fri, 24 Jul 2015 10:37:03 +0200


you could try with a direct serial connection (e.g. FTDI cable), if that works, it's an xbee problem.

To see if you can get any messages at all, you could also test with
<subsystem name="telemetry" type="transparent_usb"/>
and connect telemetry via usb (should appear as /dev/paparazzi/stm32-usb-serial or /dev/ttyACMx)

Cheers, Felix

On Fri, Jul 24, 2015 at 9:59 AM, Evgeni Todorov <address@hidden> wrote:
I tried switching around the Rx and Tx with no result, and I have UART2 set as you can see... Any more ideas what might be wrong?

Currently I am trying to get the link over serial with the Black Magic Probe but this doesn't work either. The only thing that makes sense for me is that the configuration isn't properly uploaded. Any suggestions how I might check this?

---- On Thu, 23 Jul 2015 23:42:54 -0700 Sergey Krukowski<address@hidden> wrote ----
Actually when the ap board transmit the data to the xbee and the second
xbee is paired with the first one, the pprz data flow is to see in the
terminal window of the second one.
If there are no symbols coming in terminal, but the boards are paired, it
should mean that smth wrong with the ap board to xbee connection. Either
send the board nothing over the particular uart (problems with setup) or
some problem with wiring, for example mixed up rx and tx wires.

> In XCTU I can "Discover radio nodes in the same network" and the 'Flyer'
> (i.e. the NI of my S1) is visible. The result is absolutely equivalent
> to what I see when I connect the S1 to another laptop and use the XCTU
> console to successfully receive and transmit messages.
> By 'when the board is powered' I mean when a usb is plugged in and the
> green LED is steadily alight.
> ---- On Thu, 23 Jul 2015 13:33:40 -0700 Sergey Krukowski
> &lt;address@hidden&gt; wrote ----
> Hi Evgeni!
> What do you actually mean under "when the board is powered I start XCTU
> and can detect the S1"?
> Do you see the data flow in the xctu terminal?
> &gt; Hi all,
> &gt;
> &gt; I can't get my Lisa/Mv2.0 to communicate with the GCS installed on
> &gt; Ubuntu 14.04.
> &gt;
> &gt; My configuration:
> &gt; LisaM with Aspirin 2.2 from 1 bit 2, connected via a DRX R615X
> receiver
> &gt; to a DX4e transmitter @ UART2, and via a Xbee Pro S1 and an Xbee Pro
> &gt; 802.15.4 usb adapter to my laptop.
> &gt;
> &gt; What I tried:
> &gt; 1. Checked the connection between the Lisa and the Xbee. UART2: Rx
> -&amp;gt;
> &gt; DOUT; Tx -&amp;gt; DIN; +3V3 -&amp;gt; VCC; GND -&amp;gt; GND;
> &gt; 2. Checked the configuration of the Xbee-s. Baudrates=57600 and PAN
> IDs
> &gt; are set, communication was fine between two laptops with XCTU. Also,
> &gt; when the board is powered I start XCTU and can detect the S1.
> &gt; 3. Checked the configuration of the airframe file:
> &gt; &amp;lt;!-- Communication --&amp;gt;
> &gt; &amp;lt;subsystem name="telemetry" type="transparent"&amp;gt;
> &gt; &amp;lt;configure name="MODEM_BAUD" value="B57600"/&amp;gt;
> &gt; &amp;lt;configure name="MODEM_PORT" value="UART2"/&amp;gt;
> &gt; &amp;lt;/subsystem&amp;gt;
> &gt;
> &gt; I get no errors when running the Data link program (-d /dev/ttyUSB0
> -s
> &gt; 57600) or the gcs. I do get a 'Fatal error: exception
> &gt;
> Xml.File_not_found("~/./paparazzi/conf/modules/nav_survey_rectangle_rotorcraft.xml")'
> &gt; when I run the Server though.
> &gt;
> &gt; Other (probably un)related problems:
> &gt; - The BATT/BIND port of the R615X is connected to UART1 and the
> &gt; bind procedure from
> &gt; The
> transmitter
> &gt; and receiver are binded (the LED turns on when I power up the
> receiver)
> &gt; but the servos connected don't move. I suspect the reason might be
> in
> &gt; settings, but can't verify because no telemetry.
> &gt; - When I try to browse for a different file I get the following
> &gt; error: Selected file '~/paparazzi/conf/airframes/...' should be in
> &gt; ~/./paparazzi/conf/airframes/...'. I did set the ENV variables to
> my ppz
> &gt; folder. There is a workaround, but I guess it might be related to
> the
> &gt; Server error.
> &gt;
> &gt; I am open to any suggestions, since I've checked multiple times
> &gt; everywhere I could think to check.
> &gt;
> &gt; Thanks!
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden

Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]