[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Quad Lisa M - NAV mode problem.

From: Felix Ruess
Subject: Re: [Paparazzi-devel] Quad Lisa M - NAV mode problem.
Date: Tue, 25 Aug 2015 10:59:01 +0200

Hi Luiz,

that you don't have a baro is kind of key information ;-)
Also reporting the paparazzi_version you are using and putting the complete airframe file on pastebin helps to reduce conjecture...

If you want to try without baro and use the GPS to update the vertical filter:

<define name="USE_BARO_BOARD" value="FALSE"/>
<subsystem name="ins">
  <define name="INS_USE_GPS_ALT" value="TRUE"/>

Cheers, Felix

On Tue, Aug 25, 2015 at 7:24 AM, Simon Liebold <address@hidden> wrote:
Hi Luiz,

if you have a quadcopter you will want a barometer as well. GPS altitude is usually good enough for a fixed wing. But with a rotorcraft you want to detect drift in the z axis as early as possible of as little as 10-20cm. Only a barometer can do that (yet).

I assume your GPS is an U-Blox kind as well. What generation is it (5, 6, 7 or 8 series)? My copter has an barometer but I experience issues in the horizontal axis with a lagging GPS position that we narrowed down to originate from the wrong GPS setup of my U-Blox NEO-M8N. Something I will further investigate when I get around to it.

Your symptoms seem to originate from the GPS as well. Maybe, since you don't have a barometer, you get to see the same issues on the Z-axis that I see on the horizontal axis.

Definitely invest in a barometer.

Hope that helps a bit.


Am 25.08.2015 um 02:16 schrieb Luiz Flavio Felizardo:
Hello there Simon, Indeed I left a lot of information vague, but know that you already helped with somethings.

Well, the problem happens in AP_MODE_HOVER_Z_HOLD too... in fact when I start the GCS it start with an accurate current altitude but then right after intiation it starts to change the value, sometimes it goes up indefinitely and sometimes it goes down indefinitely even if I stay at the ATT mode all the time. Ofcourse ATT works cause it does not depend on this kind of reading.

Another thing is that the current altitude and the target altitude is always the same, so the difference in GCS always show 0.

The above the ground indicator on the GCS shows a descente (in the case of the altitude decreasing for example) and a decreasing vertical speed like it is decelerating non stop starting at 0 and going down to -infinite.

All this behavior I mention only happens when I get the GPS 3D. But like I said it starts at the correct altitude and then starts going up or down forever.

My aspirin IMU has no barometer so I'm trying to get it with the GPS, I tried with some diferent INS (no type, extended for example) and AHRS values. Would you recomend something? or is it suposed to work only with the Barometer?

Last configuration tried:
    <subsystem name="ahrs"                                type="int_cmpl_quat"/>
    <configure name="USE_MAGNETOMETER"    value="TRUE"/>
    <subsystem name="ins"                                  type="extended">
        <define name="USE_BAROMETER"            value="FALSE"/>

When I use the Default Telemetry I get the ins_z and the ins_zd following the crazy altitude, the GPS altitude seems to be normal, only shows the correct value and doesnt change a lot.
The Vert Mode telemetry I havent tested yet.

What do you guys say?

Thanks very much!

On Wed, Aug 19, 2015 at 5:11 PM, Simon Liebold <address@hidden> wrote:
Hard to tell without any details. A few questions that immediately pop up:

  • Does one of the Z_HOLD modes work for you? (i.e. AP_MODE_HOVER_Z_HOLD)
  • Did you already try to record the telemetry with vert_mode while experiencing the issue?
  • Is your altitude set point in your flight plan lower than your starting point?
No, you shouldn't be going there. ;-) If your barometer is borked it will not show correct altitudes and the whole vertical loop won't work properly. Maybe a case of "garbage in, garbage out". Get that sorted out first.


Am 19.08.2015 um 19:38 schrieb Luiz Flavio Felizardo:
Hello there everyone, I am with a LISA/M, aspirin IMU Quadrotor, and I am having a problem with NAV mode, the ATT mode is working well, but when I switch to NAV and try to change the block to Start Motors, Takeoff and so on, the motor dont spin enought for a real take off, even if I am in mid air with ATT mode when I switch to NAV it simple praticaly turn off engines (note that it doesnt turn it off completely)
Another thing to consider is that the Altitude target on the GCS is climbing non stop, it says 63800m/63805m then after a second it grows a little more showing higher values.. non stop. 

Any ideas on what I might have forgotten?

A/C configuration is pretty much the "Quadrotor Lisa M 2".

Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]