[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] Rolling Spider issues (and quick joystick question)

From: Matthew Samuel Berk
Subject: [Paparazzi-devel] Rolling Spider issues (and quick joystick question)
Date: Sun, 18 Oct 2015 18:56:45 +0000

In the past couple of days I have been working on implementing Paparazzi on the Rolling Spider.

Initially I was on the fvantienen/rollingspider branch and successfully uploaded the autopilot and was able to connect telemetry via bluetooth. However, you indicated that the fvantienen/rolling_spider branch was more complete and likely would work better. Looking at the code, it does appear more ‘complete’ as it contains more Rolling Spider specific code and modules which is encouraging. Unfortunately, I am not able to get it to compile the Rolling Spider code. The output is as follows (after switching to rolling_spider branch, running

make clean && make

then opening PPZ Center and selecting bebop I get the following output

RUN 'make -C /home/matthew/paparazzinew -f AIRCRAFT=bebop ap.compile '
make: Entering directory `/home/matthew/paparazzinew'
make: *** No rule to make target `ap.compile'.  Stop.
make: Leaving directory `/home/matthew/paparazzinew'

FAILED 'make -C /home/matthew/paparazzinew -f AIRCRAFT=bebop ap.compile' with code 2

I have tried comparing diffs between the two branches but was unable to locate anything that stood out as a problem. I’m sure it’s something simple that I just don’t know about, so I was wondering if you had any quick advice. 

Also, I tried using the joystick module after writing an appropriate xml file for my Saitek X52, and get the following error:

RUN '/home/matthew/paparazzinew/sw/ground_segment/joystick/input2ivy  saitekx52.xml'
Fatal error: exception Failure("A/C 'MYAC' not found”)

I am not sure what this error means, and it appears for any joystick I select. I couldn’t find any info on it...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]