[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] GPS Not working with Paparazzi with AR Drone 2.0 H

From: nihsnek
Subject: Re: [Paparazzi-devel] GPS Not working with Paparazzi with AR Drone 2.0 Help
Date: Wed, 24 Feb 2016 23:11:18 -0800

Hey Nathan.

I've actually been through most of what you're going through now pretty recently and should be able to answer most of your questions.

I'll start by saying that you should avoid the Flight Recorder - it requires some additional setup to get working, but the quality of the GPS is too low to fly autonomously.

UBlox GPS is great - a little configuration is necessary to set this up.

Connecting by cables - you need to connect: ground to ground
RX to TX
TX to RX
and power to power.

I can't get your cable to load, but most people seem to use the FTDI 3v3 WE TTL serial to USB cables - but if your cable is up to spec, it should work.

To troubleshoot, you should telnet to the AR Drone (connect to I believe), and you have busybox to debug the device - you can use dmesg to determine if the driver loaded, and see if the serial file exists. There's some additional information on the wiki about this, I suggest you read up on that.

I'll help you more if you bug me on gitter - got to go to bed now.

Hope this helps

On Feb 24, 2016 10:19 PM, "Nathan Speidel" <address@hidden> wrote:
Hello again all!!

My partner and I are still having trouble getting the GPS to work with the Paparazzi software.   I thought I would try to post a summary of what we've done and hopefully someone can help.  

We are using the AR Parrot Drone 2.0.

We have tried two GPS units:   

A UBlox GPS which can be seen here:

and we have also tried the AR Flight recorder:

We had to wire the UBlox GPS to a SparkFun USB to Serial chip, which can bse seen here:

I have attached pictures of the back of the chip.   We soldered on some breakaway headers to the USB to serial chip, because we weren't sure what to wire the GPS to.   As you can see in the picture the GPS had 6 wires.   I think we figured out that the orange and white wires were for the compass, so we didn't wire those to anything.   We wired the black, green, red and yellow wires in various configurations including 

2. TXD, RXD, 3.3v, GND
3. TX-O, RX-I, 3v3v, GND


When we have the UBlox gps set up and we plug in the drone, the GPS lights up.   We can then run Paparazzi Center on my Linux machine and connect to the Drone wifi.   We can upload the software to the drone, but then when we execute the "Flight UDP/WiFi" session, the GPS doesn't appear to be working.    We can select the GPS tab and it just shows zeros. 

This same problem happens if we start the session with the AR Drone Flight Recorder plugged in. 

Does anyone have any thoughts about what to do next? 

What would be the next thing to do for troubleshooting? 

Inline image 2Inline image 3Inline image 1

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]