[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] twog crashes in the first 10 seconds SOLVED

From: hendrixgr .
Subject: Re: [Paparazzi-devel] twog crashes in the first 10 seconds SOLVED
Date: Fri, 3 Jun 2016 20:21:12 +0300

Felix i will be at work Sunday so i will check my laptop (i found that the software center holds all changes done)
and post back.
Also please have in mind that this happened with Ubuntu 12 LTS .

On Fri, Jun 3, 2016 at 8:15 PM, hendrixgr . <address@hidden> wrote:
Hi Felix
I am almost certain that Ubuntu 12 LTS did an upgrade in libc two or three days ago and that caused my problem because i tested the whole aircraft
Monday and it worked fine for hours.
Is there any way to check what updates were installed the last 3 days?

On Fri, Jun 3, 2016 at 5:35 PM, Felix Ruess <address@hidden> wrote:
Hm... so which exact arm-none-eabi-gcc package/version were you using that was failing?
So that we can warn others about this and put it on the wiki page...

On Fri, Jun 3, 2016 at 8:02 AM, Chris <address@hidden> wrote:
It looks like the problem was coming from an updated by ubuntu compiler because after i installed the new paparazzi arm-embedded and  completely removed manually previous versions of the compiler, the system works fine.I will keep testing it for the whole day just to be sure.
The new compiler was installed with instructions found here:

FYIfor those using Ubuntu and the gcc-arm-embedded toolchain installed via Debian package:
The old PPA maintained by Terry Guo has been replaced by team-gcc-arm-embedded and the package renamed to gcc-arm-embedded:

Cheers, Felix


Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]