[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] Suddenly unable to load to flash of Lisa/MX with Black

From: cxiao
Subject: [Paparazzi-devel] Suddenly unable to load to flash of Lisa/MX with Black Magic Probe
Date: Sun, 11 Jun 2017 12:26:41 -0700 (MST)


We have been successfully using the Lisa/MX and Black Magic Probe from
1BitSquared for several years, but yesterday, we ran into an issue where we
were not able to program the Lisa/MX. 

The error message is as follows:

Black Magic Probe (Firmware v1.6.1-27-ga4bb2c6) (Hardware Version 1)
Copyright (C) 2015  Black Sphere Technologies Ltd.
License GPLv3+: GNU GPL version 3 or later

Target voltage: 3.3V
Available Targets:
No. Att Driver
 1      STM32F4xx
A program is being debugged already.  Kill it? (y or n) [answered Y; input
not from terminal]
reset_handler () at ../../cm3/vector.c:64
64      {
Ignoring packet error, continuing...
Loading section .text, size 0x24ac8 lma 0x8000000
/home/cindy/paparazzi/sw/tools/flash_scripts/bmp_jtag_flash.scr:11: Error in
sourced command file:
Error writing data to flash

The error occurs when trying to load the binary. I have tried using GDB with
the same commands that are present in bmp_jtag_flash.scr, and I always get
the same message and failure at the same place (when trying to load the
.text section).

This error occurs:
* Using 2 different Black Magic Probes
* Using 4 different Lisa/MX boards, including one that was newly opened
* When building using the Quad_LisaMX aircraft configuration. We have also
tried with our own aircraft configuration (the "Jownsey" aircraft in our
conf file,  here
<>  ).
* We are using our own fork of paparazzi at, but this error occurs even when using
the v5.10_stable release from the main repository.

I've also looked at the option bytes on the STM32F4 to see if there's any
write protection active - there doesn't seem to be any.

We'd appreciate any pointers on where the error could be coming from, as
we've tried different hardware and software to no avail. If anyone could
help me figure out how to get a more verbose error message from GDB (I don't
think the "Error writing data to flash" message is from the BMP, although I
could be wrong), that would be great as well. Any help is appreciated as
we're a student team going to competition very soon :p

Our next step is to try using an ST-LINK rather than a BMP.


View this message in context:
Sent from the paparazzi-devel mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]