[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libxml2 and libreadline are not found

From: Ben Pfaff
Subject: Re: libxml2 and libreadline are not found
Date: Wed, 14 Nov 2007 21:57:04 -0800
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.1 (gnu/linux)

Ben Pfaff <address@hidden> writes:

> Jason Stover <address@hidden> writes:
>> configure: WARNING: The following optional prerequisites are not installed.
>> You may wish to install them to obtain additional functionality:
>>         libxml2
>>         libreadline (which may itself require libncurses or libtermcap)
>> but I have libxml2:
>> $ ls /usr/local/lib/libxml2*
>> /usr/local/lib/libxml2.a              /usr/local/lib/*            
>> /usr/local/lib/*
> Is -L/usr/local/lib in LDFLAGS?  You might also need to have
> /usr/local/lib in LD_LIBRARY_PATH.

Following my own advice, I tried that out on math and got what
you did, too.  I investigated further and discovered that
PKG_CHECK_MODULES in /usr/share/aclocal/pkg.m4 was weirdly
defective: it appears to *always* report packages as missing,
even if it tests for them and finds them to be present.

So I copied pkg.m4 from another machine (now in /home/blp/pkg.m4)
and reran configure:
        cd /home/blp/pspp
        cp /home/blp/pkg.m4 m4
        aclocal -I m4 -I gl/m4
With the fixed pkg.m4, libxml2 was properly detected.

The latest version of pkg-config is 0.22.  It looks like math has
0.19.  Beats me how 0.19 could *ever* have worked, if that's
where /usr/share/aclocal/pkg.m4 came from...

Ah, I see: it *didn't* work, see this Debian bug report:
fixed by the upstream author as a "brown bag bug where pkg.m4
always set pkg_failed to untried".

I think you should install pkg-config 0.22 on math.
"Now I have to go wash my mind out with soap."
--Derick Siddoway

reply via email to

[Prev in Thread] Current Thread [Next in Thread]