[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU PSPP 0.6.2pre3 now available

From: Ben Pfaff
Subject: Re: GNU PSPP 0.6.2pre3 now available
Date: Mon, 06 Jul 2009 06:42:39 -0700
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.3 (gnu/linux)

Matěj Cepl <address@hidden> writes:

> On 6.7.2009 07:30, Ben Pfaff wrote:
>> I'm having trouble reproducing the problem on sparc64.  I've
>> tried GCC 4.1.2 and 4.3.2, on different hosts.  I tried both -m32
>> and -m64 (even though you said that -m32 works OK).  What version
>> of GCC are you using?
> And of course, if you have Fedora installed than you SHOULD be able to
> upgrade to Rawhide, shouldn't you?
> List of mirrors for sparc64 is on
> and that includes seemingly living Rawhide (aka development).

I never managed to install Fedora on my sparc64 box, so these are
machines from the GCC Compile Farm
(  They both seem to be
running Debian, not Fedora.  I'm not eager to compile GCC myself.

I now suspect that this is a problem caused by changes in
optimization, since float-format.c does some things that should
be OK but I can imagine a compiler getting wrong (and maybe there
is some technicality that I have missed so far).  Can you try
building with "-O0" instead of the default "-O2"?


"To the engineer, the world is a toy box full of sub-optimized and
 feature-poor toys."
--Scott Adams

reply via email to

[Prev in Thread] Current Thread [Next in Thread]