[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem configuring pspp-0.10.0 on Linux Slackware 14.1

From: Frans Houweling
Subject: Re: Problem configuring pspp-0.10.0 on Linux Slackware 14.1
Date: Sat, 2 Apr 2016 19:43:24 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.7.1

Thanks. I tried (fresh untar) but get the same error.

On 02/04/2016 19:33, John Darrington wrote:
Don't modify any files.   Just run configure like this:

  ./configure CC="gcc -fgnu89-inline"


On Sat, Apr 02, 2016 at 07:24:15PM +0200, Frans Houweling wrote:
      Ehm ... I'm afraid I am on the wrong list. I did try to modify this line
      in configure:
      > ac_compile='$CC -c $CFLAGS $CPPFLAGS CFLAGS+="
      -std=c11"conftest.$ac_ext >&5'
      > ac_compile='$CC -c $CFLAGS $CPPFLAGS -fgnu89-inline CFLAGS+="
      -std=c11"conftest.$ac_ext >&5'
      to no avail.
      What is the correct way to add flags to CC?
      Thanks, frans
On 02/04/2016 18:09, John Darrington wrote:
      >On Sat, Apr 02, 2016 at 05:56:46PM +0200, Frans Houweling wrote:
      >      Trying to configure pspp-0.10.0 on Slackware 14.1 I get:
      >      >checking whether <wchar.h> uses 'inline' correctly... no
      >      >configure: error: <wchar.h> cannot be used with this compiler (gcc
      >      >-std=gnu99 -g -O2  -pthread -I/usr/include/cairo
      >      >-I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
      >      >-I/usr/include/pixman-1 -I/usr/include/freetype2
      >      >-I/usr/include/libpng14 -I/usr/include/libdrm 
      >      >).
      >      >This is a known interoperability problem of glibc <= 2.5 with gcc 
      >      >4.3 in
      >      >C99 mode. You have four options:
      >      >  - Add the flag -fgnu89-inline to CC and reconfigure, or
      >      >  - Fix your include files, using parts of
      >      >or
      >      >  - Use a gcc version older than 4.3, or
      >      >  - Don't use the flags -std=c99 or -std=gnu99.
      >Did you try the first of these options?

Attachment: config.log
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]