[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: latest patches

From: Harry Thijssen
Subject: Re: latest patches
Date: Sat, 20 Aug 2016 09:55:06 +0200


I solved this. I installed gspawn-win32-helper instead of gspawn-win32-helper-console   :-(

Have fun

2016-08-19 19:58 GMT+02:00 Harry Thijssen <address@hidden>:
Hi Friedrich

Some older post.

I am  afraid I didn't test the
else ===
At least I can't find anything about it and this doesn't work on MSwindows if the pspp.html directory and the html  files are not generated. Not a big deal as I include the html files, but it would be nice if this worked too.

Have fun

2016-05-26 13:27 GMT+02:00 Friedrich Beckmann <address@hidden>:
Hi Harry,

i did some research regarding the start of the default html browser on windows via
„start“. I have commited a new patch

which hopefully works on windows also.

The help system will look for help resources with the following priorities:

First: The yelp system, then
If the directory <docpath>/pspp.html exists
     Try the local html help files via <docpath>/pspp.html/<helppage>.html, 

To install the local html help pages (not the single page version), you have to run

make html
make install-html

This will produce <psppinstallt>/share/doc/pspp/pspp.html/index.html and other html
files in that directory. (Hopefully on windows also with suffix .html …)


Am 25.05.2016 um 14:31 schrieb Harry Thijssen <address@hidden>:

Hi Friedrich

2016-05-25 8:10 GMT+02:00 Friedrich Beckmann <>:
Hi Harry,

thanks for testing the two patches on windows!

The help function is trying the following steps

a) starting help via yelp -> this will not work in windows
b) Opening a local html file -> Depends on the existencs of a local pspp.html directory in the doc path
   I guess you have the local html installed somewhere
   <yourpsppinstall>/share/doc/pspp/pspp.html/index.html for the start page
c) Open the help via the gnu pspp internet site

You could help me debugging this with

Could you tell me the path of the pspp.html directory where you have the local html files?

I changed my procedure and copied the file pspp.html from Ben's daily tarball builds to  <yourpsppinstall>/share/doc/pspp/pspp.html 

Could you try if

start file:///<yourlocalpath>/share/doc/pspp/pspp.html/index.html

I have just 1 file copied from Bens daily builds.


works for me in a command shell. Even with a space in the file name. Surprisingly  / or \ works both. ?????

will open a browser with the help page? Could you send me the exact syntax?
Maybe with quotes? Maybe with spaces replaced by %20? I agree
that your guess with „Program Files“ indicates the problem.

With quotes and spaces but without start.  

Could you move or delete the pspp.html directory and test if psppire can
reach the internet help? I think there are no spaces in the url. It will try


In a command shell exact this line works INCLUDING start. But when started from the help page in pspp it is not shown.
Does this work on windows?


It might be easier if I apply the patches and run a test. More info can be displayed to figure out how MSWindows handles this. So we can figure out how to handle this.

Have fun

reply via email to

[Prev in Thread] Current Thread [Next in Thread]