qemu-arm
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 02/11] hw/arm/aspeed: Rename aspeed_soc_init() as AST2400/250


From: Cédric Le Goater
Subject: Re: [PATCH 02/11] hw/arm/aspeed: Rename aspeed_soc_init() as AST2400/2500 specific
Date: Wed, 25 Oct 2023 09:06:54 +0200
User-agent: Mozilla Thunderbird

On 10/24/23 18:24, Philippe Mathieu-Daudé wrote:
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>


Reviewed-by: Cédric Le Goater <clg@kaod.org>

Thanks,

C.


---
  hw/arm/aspeed_soc.c | 6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/hw/arm/aspeed_soc.c b/hw/arm/aspeed_soc.c
index f6c2ead4ac..bb377e9e6e 100644
--- a/hw/arm/aspeed_soc.c
+++ b/hw/arm/aspeed_soc.c
@@ -140,7 +140,7 @@ static qemu_irq aspeed_soc_ast2400_get_irq(AspeedSoCState 
*s, int dev)
      return qdev_get_gpio_in(DEVICE(&s->vic), sc->irqmap[dev]);
  }
-static void aspeed_soc_init(Object *obj)
+static void aspeed_ast2400_soc_init(Object *obj)
  {
      AspeedSoCState *s = ASPEED_SOC(obj);
      AspeedSoCClass *sc = ASPEED_SOC_GET_CLASS(s);
@@ -546,7 +546,7 @@ static void aspeed_soc_ast2400_class_init(ObjectClass *oc, 
void *data)
  static const TypeInfo aspeed_soc_ast2400_type_info = {
      .name           = "ast2400-a1",
      .parent         = TYPE_ASPEED_SOC,
-    .instance_init  = aspeed_soc_init,
+    .instance_init  = aspeed_ast2400_soc_init,
      .instance_size  = sizeof(AspeedSoCState),
      .class_init     = aspeed_soc_ast2400_class_init,
  };
@@ -573,7 +573,7 @@ static void aspeed_soc_ast2500_class_init(ObjectClass *oc, 
void *data)
  static const TypeInfo aspeed_soc_ast2500_type_info = {
      .name           = "ast2500-a1",
      .parent         = TYPE_ASPEED_SOC,
-    .instance_init  = aspeed_soc_init,
+    .instance_init  = aspeed_ast2400_soc_init,
      .instance_size  = sizeof(AspeedSoCState),
      .class_init     = aspeed_soc_ast2500_class_init,
  };




reply via email to

[Prev in Thread] Current Thread [Next in Thread]