qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 371d60: configure: Fix error message when C c


From: Richard Henderson
Subject: [Qemu-commits] [qemu/qemu] 371d60: configure: Fix error message when C compiler is no...
Date: Tue, 14 May 2024 08:24:45 -0700

  Branch: refs/heads/staging
  Home:   https://github.com/qemu/qemu
  Commit: 371d60dfdb47dd18d163a7759968ba138089371e
      
https://github.com/qemu/qemu/commit/371d60dfdb47dd18d163a7759968ba138089371e
  Author: Thomas Huth <thuth@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M configure

  Log Message:
  -----------
  configure: Fix error message when C compiler is not working

If you try to run the configure script on a system without a working
C compiler, you get a very misleading error message:

 ERROR: Unrecognized host OS (uname -s reports 'Linux')

Some people already opened bug tickets because of this problem:

 https://gitlab.com/qemu-project/qemu/-/issues/2057
 https://gitlab.com/qemu-project/qemu/-/issues/2288

We should rather tell the user that we were not able to use the C
compiler instead, otherwise they will have a hard time to figure
out what was going wrong.

While we're at it, let's also suppress the "unrecognized host CPU"
message in this case since it is rather misleading than helpful.

Fixes: 264b803721 ("configure: remove compiler sanity check")
Message-ID: <20240513114010.51608-1-thuth@redhat.com>
Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: bad7a2759c69417a5558f0f19d4ede58c08705e8
      
https://github.com/qemu/qemu/commit/bad7a2759c69417a5558f0f19d4ede58c08705e8
  Author: Daniel P. Berrangé <berrange@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M tests/docker/dockerfiles/debian-all-test-cross.docker
    M tests/docker/dockerfiles/debian-hexagon-cross.docker
    M tests/docker/dockerfiles/debian-legacy-test-cross.docker
    M tests/docker/dockerfiles/debian-loongarch-cross.docker
    M tests/docker/dockerfiles/debian-tricore-cross.docker
    M tests/docker/dockerfiles/debian-xtensa-cross.docker
    M tests/docker/dockerfiles/fedora-cris-cross.docker

  Log Message:
  -----------
  dockerfiles: add 'MAKE' env variable to remaining containers

All the lcitool generated containers define a "MAKE" env. It will be
convenient for later patches if all containers do this.

Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Reviewed-by: Thomas Huth <thuth@redhat.com>
Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Message-ID: <20240513111551.488088-2-berrange@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: c53f7a107879a2b7e719b07692a05289bf603fde
      
https://github.com/qemu/qemu/commit/c53f7a107879a2b7e719b07692a05289bf603fde
  Author: Daniel P. Berrangé <berrange@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M .gitlab-ci.d/buildtest-template.yml

  Log Message:
  -----------
  gitlab: use $MAKE instead of 'make'

The lcitool generated containers have '$MAKE' set to the path
of the right 'make' binary. Using the env variable makes it
possible to override the choice per job.

Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Reviewed-by: Thomas Huth <thuth@redhat.com>
Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Message-ID: <20240513111551.488088-3-berrange@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: b563959b906db53fb4bcaef1351f11a51c4b9582
      
https://github.com/qemu/qemu/commit/b563959b906db53fb4bcaef1351f11a51c4b9582
  Author: Daniel P. Berrangé <berrange@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M .gitlab-ci.d/buildtest.yml

  Log Message:
  -----------
  gitlab: use 'setarch -R' to workaround tsan bug

The TSAN job started failing when gitlab rolled out their latest
release. The root cause is a change in the Google COS version used
on shared runners. This brings a kernel running with

 vm.mmap_rnd_bits = 31

which is incompatible with TSAN in LLVM < 18, which only supports
upto '28'. LLVM 18 can support upto '30', and failing that will
re-exec itself to turn off VA randomization.

Our LLVM is too old for now, but we can run with 'setarch -R make ..'
to turn off VA randomization ourselves.

Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Reviewed-by: Thomas Huth <thuth@redhat.com>
Message-ID: <20240513111551.488088-4-berrange@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: 0d8caac9042667edd4198144035cff770b3691cf
      
https://github.com/qemu/qemu/commit/0d8caac9042667edd4198144035cff770b3691cf
  Author: Thomas Huth <thuth@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M include/glib-compat.h
    M meson.build
    M qga/commands-posix-ssh.c

  Log Message:
  -----------
  Bump minimum glib version to v2.66

Now that we dropped support for CentOS 8 and Ubuntu 20.04, we can
look into bumping the glib version to a new minimum for further
clean-ups. According to repology.org, available versions are:

 CentOS Stream 9:       2.66.7
 Debian 11:             2.66.8
 Fedora 38:             2.74.1
 Freebsd:               2.78.4
 Homebrew:              2.80.0
 Openbsd:               2.78.4
 OpenSuse leap 15.5:    2.70.5
 pkgsrc_current:        2.78.4
 Ubuntu 22.04:          2.72.1

Thus it should be safe to bump the minimum glib version to 2.66 now.
Version 2.66 comes with new functions for URI parsing which will
allow further clean-ups in the following patches.

Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
Message-ID: <20240418101056.302103-8-thuth@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: 82fe5d08fd8b83173e506d266e614d0dca5f2088
      
https://github.com/qemu/qemu/commit/82fe5d08fd8b83173e506d266e614d0dca5f2088
  Author: Thomas Huth <thuth@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M qga/commands-posix-ssh.c
    M util/error-report.c

  Log Message:
  -----------
  Remove glib compatibility code that is not required anymore

Now that we bumped the minimum glib version to 2.66, we can drop
the old code.

Suggested-by: Paolo Bonzini <pbonzini@redhat.com>
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
Message-ID: <20240418101056.302103-9-thuth@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: 3413c6628b71c865da354590c3b05aa1f55a0729
      
https://github.com/qemu/qemu/commit/3413c6628b71c865da354590c3b05aa1f55a0729
  Author: Thomas Huth <thuth@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M block/gluster.c

  Log Message:
  -----------
  block/gluster: Use URI parsing code from glib

Since version 2.66, glib has useful URI parsing functions, too.
Use those instead of the QEMU-internal ones to be finally able
to get rid of the latter.

Since g_uri_get_path() returns a const pointer, we also need to
tweak the parameter of parse_volume_options() (where we use the
result of g_uri_get_path() as input).

Reviewed-by: Eric Blake <eblake@redhat.com>
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
Message-Id: <20240418101056.302103-10-thuth@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: ad97c011dcb0e5b5e1eae50c0f8ddb89281056e4
      
https://github.com/qemu/qemu/commit/ad97c011dcb0e5b5e1eae50c0f8ddb89281056e4
  Author: Thomas Huth <thuth@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M block/nbd.c

  Log Message:
  -----------
  block/nbd: Use URI parsing code from glib

Since version 2.66, glib has useful URI parsing functions, too.
Use those instead of the QEMU-internal ones to be finally able
to get rid of the latter. The g_uri_get_host() also takes care
of removing the square brackets from IPv6 addresses, so we can
drop that part of the QEMU code now, too.

Reviewed-by: Richard W.M. Jones <rjones@redhat.com>
Reviewed-by: Eric Blake <eblake@redhat.com>
Message-ID: <20240418101056.302103-11-thuth@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: f8b74fc55dcceacf793bd72afb1c6432b33655ca
      
https://github.com/qemu/qemu/commit/f8b74fc55dcceacf793bd72afb1c6432b33655ca
  Author: Thomas Huth <thuth@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M block/nfs.c

  Log Message:
  -----------
  block/nfs: Use URI parsing code from glib

Since version 2.66, glib has useful URI parsing functions, too.
Use those instead of the QEMU-internal ones to be finally able
to get rid of the latter.

While we're at it, slightly rephrase one of the error messages:
Use "Invalid value..." instead of "Illegal value..." since the
latter rather sounds like the users were breaking a law here.

Reviewed-by: Eric Blake <eblake@redhat.com>
Message-ID: <20240418101056.302103-12-thuth@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: a22a97d8056841f1d6d8e52d39281c8c01f4117b
      
https://github.com/qemu/qemu/commit/a22a97d8056841f1d6d8e52d39281c8c01f4117b
  Author: Thomas Huth <thuth@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M block/ssh.c

  Log Message:
  -----------
  block/ssh: Use URI parsing code from glib

Since version 2.66, glib has useful URI parsing functions, too.
Use those instead of the QEMU-internal ones to be finally able
to get rid of the latter.

While we're at it, also emit a warning when encountering unknown
parameters in the URI, so that the users have a chance to detect
their typos or other mistakes.

Reviewed-by: Richard W.M. Jones <rjones@redhat.com>
Message-ID: <20240418101056.302103-13-thuth@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: da79537e0c8cef007d30298343d05acb0ba8b427
      
https://github.com/qemu/qemu/commit/da79537e0c8cef007d30298343d05acb0ba8b427
  Author: Thomas Huth <thuth@redhat.com>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    R include/qemu/uri.h
    M util/meson.build
    R util/uri.c

  Log Message:
  -----------
  util/uri: Remove the old URI parsing code

Now that we switched all consumers of the URI code to use the URI
parsing functions from glib instead, we can remove our internal
URI parsing code since it is not used anymore.

Reviewed-by: Eric Blake <eblake@redhat.com>
Message-ID: <20240418101056.302103-14-thuth@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>


  Commit: 3d48b6b687c558a042d91370633b91c6e29e0e05
      
https://github.com/qemu/qemu/commit/3d48b6b687c558a042d91370633b91c6e29e0e05
  Author: Richard Henderson <richard.henderson@linaro.org>
  Date:   2024-05-14 (Tue, 14 May 2024)

  Changed paths:
    M .gitlab-ci.d/buildtest-template.yml
    M .gitlab-ci.d/buildtest.yml
    M block/gluster.c
    M block/nbd.c
    M block/nfs.c
    M block/ssh.c
    M configure
    M include/glib-compat.h
    R include/qemu/uri.h
    M meson.build
    M qga/commands-posix-ssh.c
    M tests/docker/dockerfiles/debian-all-test-cross.docker
    M tests/docker/dockerfiles/debian-hexagon-cross.docker
    M tests/docker/dockerfiles/debian-legacy-test-cross.docker
    M tests/docker/dockerfiles/debian-loongarch-cross.docker
    M tests/docker/dockerfiles/debian-tricore-cross.docker
    M tests/docker/dockerfiles/debian-xtensa-cross.docker
    M tests/docker/dockerfiles/fedora-cris-cross.docker
    M util/error-report.c
    M util/meson.build
    R util/uri.c

  Log Message:
  -----------
  Merge tag 'pull-request-2024-05-14' of https://gitlab.com/thuth/qemu into 
staging

* Fix the "tsan-build" CI job on the shared gitlab CI runners
* Bump minimum glib version and use URI code from the newer glib
* Fix error message from "configure" when C compiler is not working

# -----BEGIN PGP SIGNATURE-----
#
# iQJFBAABCAAvFiEEJ7iIR+7gJQEY8+q5LtnXdP5wLbUFAmZDXcYRHHRodXRoQHJl
# ZGhhdC5jb20ACgkQLtnXdP5wLbVPJw//bK/NuMKOHlnwgowkQ/x41t8nc0jAR38+
# aMhJBTSB+9EOlPd+/y7+IeFlD9lS2JzoX/CWeBrNlKc6juWQahABJYcvscmdGiYr
# a/dUy9iZoqJyY220TMjCWYwORRtNqPDXaiUIR8hBZZBmW51xs1hRc3aazxPm6dOD
# cj1yFKwWGY5g72SkRNTMWi3qWX1tXNOh7sbuhWKkZ3eiRCllHb0RwrhA341ze4TI
# ckmlSA6stMjls4XNAIAKVdRKLPE1BsJ/UKxpnOEO3F640cbe69B0+z13wIBNfTOY
# Mk3zSjrdLY6thSY+2iOb2FLt3wC5QCBjyRluv+0kwdSnz6xsafEDWNx5VneZH+Iu
# ZQWLGvN4qUUBBqHKY8eWnrsij3ABXioHLK8eHj2JuHidcG15tku/1cwAJvy/8P/O
# iup0elZ3MXaAk6ce3dwYY4t6QecuzqX9cdJkTuRNlzysK1xKQdBiYTdeZikfUAoM
# InuFUh732yPXDSiZcG+uMXUTAJXHWASr7bvPydDx/gL1tYGYBqYepfPF2uWYfNwg
# VZRgsN6WVDBGPyXv8Z7eQ9lye5JoAGYrSDxZE87q8RwRV5holiYDxtf10zeLz3Wf
# RI5L/bb2eFSHzi3quzOC1uLflLqNKwq+9UZEjdLv2z8zuhwVwxbcDV9+ox6zA8zi
# dnVC3Yp/3ik=
# =VRHz
# -----END PGP SIGNATURE-----
# gpg: Signature made Tue 14 May 2024 02:49:10 PM CEST
# gpg:                using RSA key 27B88847EEE0250118F3EAB92ED9D774FE702DB5
# gpg:                issuer "thuth@redhat.com"
# gpg: Good signature from "Thomas Huth <th.huth@gmx.de>" [full]
# gpg:                 aka "Thomas Huth <thuth@redhat.com>" [full]
# gpg:                 aka "Thomas Huth <th.huth@posteo.de>" [unknown]
# gpg:                 aka "Thomas Huth <huth@tuxfamily.org>" [full]

* tag 'pull-request-2024-05-14' of https://gitlab.com/thuth/qemu:
  util/uri: Remove the old URI parsing code
  block/ssh: Use URI parsing code from glib
  block/nfs: Use URI parsing code from glib
  block/nbd: Use URI parsing code from glib
  block/gluster: Use URI parsing code from glib
  Remove glib compatibility code that is not required anymore
  Bump minimum glib version to v2.66
  gitlab: use 'setarch -R' to workaround tsan bug
  gitlab: use $MAKE instead of 'make'
  dockerfiles: add 'MAKE' env variable to remaining containers
  configure: Fix error message when C compiler is not working

Signed-off-by: Richard Henderson <richard.henderson@linaro.org>


Compare: https://github.com/qemu/qemu/compare/936007019678...3d48b6b687c5

To unsubscribe from these emails, change your notification settings at 
https://github.com/qemu/qemu/settings/notifications



reply via email to

[Prev in Thread] Current Thread [Next in Thread]