qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 2/3] Acceptance Tests: move definition of distro checksums to


From: Wainer dos Santos Moschetta
Subject: Re: [PATCH 2/3] Acceptance Tests: move definition of distro checksums to the framework
Date: Mon, 19 Apr 2021 12:25:44 -0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.7.0

Hi,

On 4/14/21 7:14 PM, Cleber Rosa wrote:
Instead of having, by default, the checksum in the tests, and the
definition of tests in the framework, let's keep them together.

A central definition for distributions is available, and it should
allow other known distros to be added more easily.

No behavior change is expected here, and tests can still define
a distro_checksum value if for some reason they want to override
the known distribution information.

Signed-off-by: Cleber Rosa <crosa@redhat.com>
---
  tests/acceptance/avocado_qemu/__init__.py | 34 +++++++++++++++++++++--
  tests/acceptance/boot_linux.py            |  8 ------
  2 files changed, 32 insertions(+), 10 deletions(-)

diff --git a/tests/acceptance/avocado_qemu/__init__.py 
b/tests/acceptance/avocado_qemu/__init__.py
index aae1e5bbc9..97093614d9 100644
--- a/tests/acceptance/avocado_qemu/__init__.py
+++ b/tests/acceptance/avocado_qemu/__init__.py
@@ -299,6 +299,30 @@ def ssh_command(self, command):
          return stdout_lines, stderr_lines
+#: A collection of known distros and their respective image checksum
+KNOWN_DISTROS = {

Do you plan to expand that mapping to record values other than checksums? Otherwise it could be named KNOWN_DISTROS_CHECKSUMS.

+    'fedora': {
+        '31': {
+            'x86_64':
+            {'checksum': 
'e3c1b309d9203604922d6e255c2c5d098a309c2d46215d8fc026954f3c5c27a0'},
+            'aarch64':
+            {'checksum': 
'1e18d9c0cf734940c4b5d5ec592facaed2af0ad0329383d5639c997fdf16fe49'},
+            'ppc64':
+            {'checksum': 
'7c3528b85a3df4b2306e892199a9e1e43f991c506f2cc390dc4efa2026ad2f58'},
+            's390x':
+            {'checksum': 
'4caaab5a434fd4d1079149a072fdc7891e354f834d355069ca982fdcaf5a122d'},
+            }
+        }
+    }
+
+
+def get_known_distro_checksum(distro, distro_version, arch):
+    try:
+        return 
KNOWN_DISTROS.get(distro).get(distro_version).get(arch).get('checksum')
+    except AttributeError:
+        return None
+
+

Currently we have a few loose methods on avocado_qemu/__init__.py, and I'm about to send a series to wrap them in a mixin class. This series will introduce more loose code on the file; so would you consider moving KNOWN_DISTROS and get_known_distro_checksum() to the LinuxTest class, and possibly making the latest a class method?

  class LinuxTest(Test, LinuxSSHMixIn):
      """Facilitates having a cloud-image Linux based available.
@@ -348,14 +372,20 @@ def download_boot(self):
          vmimage.QEMU_IMG = qemu_img
self.log.info('Downloading/preparing boot image')
+        distro = 'fedora'
+        distro_version = '31'
+        known_distro_checksum = get_known_distro_checksum(distro,
+                                                          distro_version,
+                                                          self.arch)
+        distro_checksum = self.distro_checksum or known_distro_checksum


distro_checksum may be None. In this case vmimage.get() will silently skip the check? I suggest to log a warn message.


          # Fedora 31 only provides ppc64le images
          image_arch = self.arch
          if image_arch == 'ppc64':
              image_arch = 'ppc64le'
          try:
              boot = vmimage.get(
-                'fedora', arch=image_arch, version='31',
-                checksum=self.distro_checksum,
+                distro, arch=image_arch, version=distro_version,
+                checksum=distro_checksum,
                  algorithm='sha256',
                  cache_dir=self.cache_dirs[0],
                  snapshot_dir=self.workdir)
diff --git a/tests/acceptance/boot_linux.py b/tests/acceptance/boot_linux.py
index c7bc3a589e..9e618c6daa 100644
--- a/tests/acceptance/boot_linux.py
+++ b/tests/acceptance/boot_linux.py
@@ -20,8 +20,6 @@ class BootLinuxX8664(LinuxTest):
      :avocado: tags=arch:x86_64
      """
- distro_checksum = 'e3c1b309d9203604922d6e255c2c5d098a309c2d46215d8fc026954f3c5c27a0'
-
      def test_pc_i440fx_tcg(self):
          """
          :avocado: tags=machine:pc
@@ -66,8 +64,6 @@ class BootLinuxAarch64(LinuxTest):
      :avocado: tags=machine:gic-version=2
      """
- distro_checksum = '1e18d9c0cf734940c4b5d5ec592facaed2af0ad0329383d5639c997fdf16fe49'
-
      def add_common_args(self):
          self.vm.add_args('-bios',
                           os.path.join(BUILD_DIR, 'pc-bios',
@@ -119,8 +115,6 @@ class BootLinuxPPC64(LinuxTest):
      :avocado: tags=arch:ppc64
      """
- distro_checksum = '7c3528b85a3df4b2306e892199a9e1e43f991c506f2cc390dc4efa2026ad2f58'
-
      def test_pseries_tcg(self):
          """
          :avocado: tags=machine:pseries
@@ -136,8 +130,6 @@ class BootLinuxS390X(LinuxTest):
      :avocado: tags=arch:s390x
      """
- distro_checksum = '4caaab5a434fd4d1079149a072fdc7891e354f834d355069ca982fdcaf5a122d'
-
      @skipIf(os.getenv('GITLAB_CI'), 'Running on GitLab')
      def test_s390_ccw_virtio_tcg(self):
          """




reply via email to

[Prev in Thread] Current Thread [Next in Thread]