qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 1/6] hw/acpi/viot: rename build_pci_range_node() to pci_host_


From: Ani Sinha
Subject: Re: [PATCH 1/6] hw/acpi/viot: rename build_pci_range_node() to pci_host_bridges()
Date: Wed, 18 May 2022 17:06:28 +0530

On Wed, May 18, 2022 at 4:38 PM Mark Cave-Ayland
<mark.cave-ayland@ilande.co.uk> wrote:
>
> This is in preparation for separating out the VIOT ACPI table build from the
> PCI host bridge numeration.
>
> Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
> ---
>  hw/acpi/viot.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/hw/acpi/viot.c b/hw/acpi/viot.c
> index c1af75206e..2897aa8c88 100644
> --- a/hw/acpi/viot.c
> +++ b/hw/acpi/viot.c
> @@ -17,7 +17,7 @@ struct viot_pci_ranges {
>  };
>
>  /* Build PCI range for a given PCI host bridge */
> -static int build_pci_range_node(Object *obj, void *opaque)
> +static int pci_host_bridges(Object *obj, void *opaque)

Please rename this as build_pci_host_bridges()

>  {
>      struct viot_pci_ranges *pci_ranges = opaque;
>      GArray *blob = pci_ranges->blob;
> @@ -78,7 +78,7 @@ void build_viot(MachineState *ms, GArray *table_data, 
> BIOSLinker *linker,
>      };
>
>      /* Build the list of PCI ranges that this viommu manages */
> -    object_child_foreach_recursive(OBJECT(ms), build_pci_range_node,
> +    object_child_foreach_recursive(OBJECT(ms), pci_host_bridges,
>                                     &pci_ranges);
>
>      /* ACPI table header */
> --
> 2.20.1
>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]