qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [qemu PATCH] hw/cxl/cxl_device: Replace magic number in CXLError def


From: Davidlohr Bueso
Subject: Re: [qemu PATCH] hw/cxl/cxl_device: Replace magic number in CXLError definition
Date: Tue, 14 Mar 2023 10:29:10 -0700
User-agent: NeoMutt/20220429

On Tue, 14 Mar 2023, Fan Ni wrote:

Replace the magic number 32 with CXL_RAS_ERR_HEADER_NUM for better code
readability and maintainability.


Reviewed-by: Davidlohr Bueso <dave@stgolabs.net>

Signed-off-by: Fan Ni <fan.ni@samsung.com>
---
include/hw/cxl/cxl_device.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/hw/cxl/cxl_device.h b/include/hw/cxl/cxl_device.h
index d589f78202..34fde62eac 100644
--- a/include/hw/cxl/cxl_device.h
+++ b/include/hw/cxl/cxl_device.h
@@ -235,7 +235,7 @@ REG64(CXL_MEM_DEV_STS, 0)
typedef struct CXLError {
    QTAILQ_ENTRY(CXLError) node;
    int type; /* Error code as per FE definition */
-    uint32_t header[32];
+    uint32_t header[CXL_RAS_ERR_HEADER_NUM];
} CXLError;

typedef QTAILQ_HEAD(, CXLError) CXLErrorList;
--
2.25.1



reply via email to

[Prev in Thread] Current Thread [Next in Thread]