qemu-ppc
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] target/ppc: Rename variables to avoid local variable shadowi


From: Cédric Le Goater
Subject: Re: [PATCH] target/ppc: Rename variables to avoid local variable shadowing in VUPKPX
Date: Sat, 23 Sep 2023 17:59:35 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.13.0

On 9/23/23 10:25, Michael Tokarev wrote:
23.09.2023 10:12, Cédric Le Goater:

--- a/target/ppc/int_helper.c
+++ b/target/ppc/int_helper.c
@@ -2022,11 +2022,11 @@ void helper_vsum4ubs(CPUPPCState *env, ppc_avr_t *r, 
ppc_avr_t *a, ppc_avr_t *b)
          for (i = 0; i < ARRAY_SIZE(r->u32); i++) {                      \
              uint16_t e = b->u16[hi ? i : i + 4];                        \
              uint8_t a = (e >> 15) ? 0xff : 0;                           \
-            uint8_t r = (e >> 10) & 0x1f;                               \
+            uint8_t _r = (e >> 10) & 0x1f;                              \
              uint8_t g = (e >> 5) & 0x1f;                                \
-            uint8_t b = e & 0x1f;                                       \
+            uint8_t _b = e & 0x1f;                                      \

I'd suggest to rename all of them here to have the same pattern.  Maybe.. :)

or maybe use the field names from the ISA : VRT,VRA,VRB ?

C.






reply via email to

[Prev in Thread] Current Thread [Next in Thread]