[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[RP] msgwait missing from my source code

From: Kevin Geiss
Subject: [RP] msgwait missing from my source code
Date: Wed Jun 30 21:50:02 2004
User-agent: Mutt/1.5.6i

I need to investigate more tomorrow...can anyone give me insight into
how the commands are set up in the source code?

The reason I ask is that I have gentoo installed on my ibook and also on
all my desktop machines. There wasn't an ebuild for the 1.3 final version
of ratpoison, just for one of the release candidates. I renamed the last
ebuild so it was named ratpoison-1.3.0.ebuild then emerged ratpoison.

I did that on my ibook and also on my x86 desktop machines.

I then ran ratpoison, hit ctl-t : then typed 'msgwait 10' at the prompt.

on my desktop machines, it worked fine.

on the ibook, it told me there was no such command. I was surprised.

I looked into the source code.  I found the large array where the commands
get registered (the thing where there's a string with the name of the
command, and the pointer to the function which handles it). there was
no entry for msgwait in the source code that my ibook got. (the msgwait
function was there)

I added the msgwait line by hand, then had portage build and install
it. then after re-running ratpoison, msgwait worked.

I guess I'm wondering if the large array which sets up the function
pointers to the individual commands is generated somewhere, or if it
was written by hand?

I still have my hacked source tree, so tomorrow I plan to try some diffs
between it and the source trees I got on my x86 boxes. tomorrow I can
be more specific with source file names and line numbers too

reply via email to

[Prev in Thread] Current Thread [Next in Thread]