[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Installation problem in SunOS

From: Xiao-Hua Kong
Subject: Installation problem in SunOS
Date: Thu, 2 Sep 2004 17:50:57 -0400 (EDT)


I am working on something with finite domain solver. 
After I have used GNU Prolog in windowns, I decided to install one on UNIX
so I can integrate it with other tools. 
The following is the error information I got during the installation.

- Following the instruction given in INSTALL file, I go to ./src and run
script configure, and I got the message:
checking for gcc... no
checking for cc... cc
checking for C compiler default output... configure: error: C compiler
cannot create executables

I could not figure out what was wrong (by my limited UNIX knowledge :-( ).

Then I just typed 
make install 
It seems the install does start even I did not go through configuration
correctly. But it stop somewhere and gave error information again:
mkdir /home/kong/GNU_Prolog/gprolog-1.2.16/ExamplesFD
if test /home/kong/GNU_Prolog/bin != none; then \
   (cd /home/kong/GNU_Prolog/bin 2>/dev/null && rm -f gplc hexgplc gprolog
pl2wam wam2ma ma2asm fd2c); \
   rmdir /home/kong/GNU_Prolog/bin 2>/dev/null; \
fi || exit 0;
*** Error code 2
make: Fatal error: Command failed for target `uninstall-links'

Since it stopped when it was uninstalling something, I tried to run the
gprolog under /bin and it worked (at least for FD solver). 

Now I am wondering what was wrong with my installation. Can any one give
a solution, or some confidence on using it with so many errors in


Xiaohua Kong                    __ O_     Off. : (514)398-3937
Ph.D. Candidate                   // \    Home : (514)636-8029     
Microelectronics And             //       Cell : (514)826-8029           
Computer System Laboratory     O /        Fax  : (514)636-8029
Dept. of ECE                   ------     Email: address@hidden    
McGill University, Montreal    ----                  

reply via email to

[Prev in Thread] Current Thread [Next in Thread]