[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compilation error on Mac OS X 10.5.5

From: Alexandre Saidi
Subject: Re: Compilation error on Mac OS X 10.5.5
Date: Mon, 13 Oct 2008 14:12:52 +0200
User-agent: Thunderbird (X11/20080914)

Thanks to  all for that help.
I did it on a G5 PPC.
It works fine.
Traces are the same as you.


Marcello Azambuja a écrit :
As I suspected I upgraded my XCode (3.1 beta) to XCode 3.1.1 and that upgraded ld and everything else:

$ ld -v
@(#)PROGRAM:ld  PROJECT:ld64-82.5
$ ld_classic -v
Apple Computer, Inc. version cctools-667.3~112

After the upgrade:

$ ld -v
@(#)PROGRAM:ld  PROJECT:ld64-85.2.1
$ ld_classic -v
Apple Computer, Inc. version cctools-698.1~1

Everything is working fine now, seems ld 82.5 had a bug in it, XCode upgrade fixed the problem. :)

$ ./gprolog --version
Prolog top-Level (GNU Prolog) 1.3.0
By Daniel Diaz
Copyright (C) 1999-2007 Daniel Diaz

Marcello Azambuja

On Tue, Oct 7, 2008 at 10:19 PM, Marcello Azambuja <address@hidden> wrote:
As a follow up, I tried to compile it in a different Mac, with same MacOS X 10.5.5 (Darwin 9.5.0) and gcc 4.0.1.

But in this new machine everything compiled fine, so I checked ld version:

Not working:
$ ld -v
@(#)PROGRAM:ld  PROJECT:ld64-82.5

$ ld -v
@(#)PROGRAM:ld  PROJECT:ld64-85

I could also find in google that other people had the very same problem with other projects and some could get it solved running:

./configure --with-ld=/usr/bin/ld_classic

But as far as I could check gprolog's configure ignores this option and I could not find any way to force ld_classic to be used.

ld_classic version is also older in the machine that is not working:

Not working:
$ ld_classic -v
Apple Computer, Inc. version cctools-667.3~112

$ ld_classic -v
Apple Computer, Inc. version cctools-668~13

I'll try to update the not-working machine, hope that will solve the problem.

Marcello Azambuja

On Tue, Oct 7, 2008 at 2:05 PM, Marcello Azambuja <address@hidden> wrote:

I'm trying to compile gprolog on my MacBook Pro running Mac OS X 10.5.5 (Darwin 9.5.0) with gcc 4.0.1.

I tried downloading gprolog-1.3.0.tar.gz but could not compile it (configure && make):

gplc -o pl2wam --no-fd-lib --min-bips pl2wam.o read_file.o bip_list.o syn_sugar.o internal.o code_gen.o reg_alloc.o inst_codif.o first_arg.o indexing.o wam_emit.o
collect2: ld terminated with signal 10 [Bus error]
Undefined symbol: predicate($pl_query_recover_alt/0)
Undefined symbol: predicate($pl_query_recover_alt/0)
compilation failed
make[1]: *** [pl2wam] Error 1
make: *** [all] Error 1

I also tried 'port install gprolog' but got the same error (it basically does the same that I did).

I searched the list archives but could only find a message from two years ago suggesting to use gcc 3.x.

Any help is appreciated.


Marcello Azambuja

_______________________________________________ Users-prolog mailing list address@hidden

Alexandre S. Saidi
Maître de Conférences
Ecole Centrale de Lyon
Département Mathématiques-Informatique
Mél : address@hidden
Tél :, Fax :

Attachment: Alexandre_Saidi.vcf
Description: Vcard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]