automake
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

different name for debug and release library/program


From: Juraj Hercek
Subject: different name for debug and release library/program
Date: Wed, 30 Apr 2003 11:29:55 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Hi,

I'd like to have different name for debug and release library/program. Is it possible to use something like this?:
---
if DEBUG
NAME=foo
else
NAME=fooDebug
endif

bin_PROGRAMS = $(NAME)
$(NAME)_SOURCES = foo.c
---
or use "@address@hidden = foo.c" instead of "$(NAME)_SOURCES = foo.c"...

If not, is there a way how to solve this without explicitly specifying name? I.e.:
---
foo_SOURCES = foo.c
fooDebug_SOURCES=foo.c
---

Thanks,
Juraj





reply via email to

[Prev in Thread] Current Thread [Next in Thread]