automake
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: different name for debug and release library/program


From: Guido Draheim
Subject: Re: different name for debug and release library/program
Date: Wed, 30 Apr 2003 17:36:23 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.1) Gecko/20020826

sh libtool --mode=link --help

Note the -release and -version-info arguments.

Add some "mylib_la_LDFLAGS = -release suffix" to get the library
being installed as libmylib-suffix.so - that will not work
for programs where you should check for transform_name
in the configure-script (otherwise settable via that
sh configure --program-suffix etcetara).

have fun, guido


Juraj Hercek schrieb:
Hi,

I'd like to have different name for debug and release library/program. Is it possible to use something like this?:
---
if DEBUG
NAME=foo
else
NAME=fooDebug
endif

bin_PROGRAMS = $(NAME)
$(NAME)_SOURCES = foo.c
---
or use "@address@hidden = foo.c" instead of "$(NAME)_SOURCES = foo.c"...

If not, is there a way how to solve this without explicitly specifying name? I.e.:
---
foo_SOURCES = foo.c
fooDebug_SOURCES=foo.c
---

Thanks,
Juraj









reply via email to

[Prev in Thread] Current Thread [Next in Thread]