[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
RE: A little patch in CharArrayWriter.java
From: |
Wu, Gansha |
Subject: |
RE: A little patch in CharArrayWriter.java |
Date: |
Tue, 31 Jul 2001 12:57:35 +0800 |
- if ((buf.length - count) < (len % buffer_increment_size))
+ if ((this.buf.length - count) < (len % buffer_increment_size))
^^^^^^
Because of some reason I couldn't submit a diff file. Sorry for that.
Regards...
Gansha
-----Original Message-----
From: Tom Tromey [mailto:address@hidden
Sent: 2001?7?31? 13:02
To: Wu, Gansha
Cc: 'address@hidden'
Subject: Re: A little patch in CharArrayWriter.java
>>>>> "Gansha" == Wu, Gansha <address@hidden> writes:
Gansha> Consider this snippet in java/io/CharArrayWriter.java:
Gansha> Obviously "this." should be added, there're two "buf" here
Gansha> incidently, one is input argument, the other is a field of
Gansha> this.
Where should `this.' be added? I don't see an obvious place.
Best would be a unidiff.
This code seems overly complex for what it has to do.
What if we just merge with libgcj, largely keeping the libgcj
implementation?
Tom