qemu-riscv
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 0/4] target/riscv: rename ext_i* to ext_zi*


From: Daniel Henrique Barboza
Subject: [PATCH 0/4] target/riscv: rename ext_i* to ext_zi*
Date: Thu, 12 Oct 2023 13:46:00 -0300

Hi,

This series renames the following internal extensions flags:

ext_ifencei, ext_icsr, ext_icbom, ext_icboz

To add a leading 'z':

ext_zifencei, ext_zicsr, ext_zicbom, ext_zicboz

This was proposed by Andrew Jones. The motivation, in his own words:

"I'd prefer we name the booleans with their 'z' to improve grepping.
When one wants to search for uses of zifencei, I imagine they're more
likely to do 'grep -i zifencei' than 'grep -i ifencei', particularly
because the 's' is maintained for S extensions. "


Aside from that, these are the only 4 Z-extension flags that don't use a
leading 'z' in their name, so there's also the benefit of making
everything equal.



Daniel Henrique Barboza (4):
  target/riscv: rename ext_ifencei to ext_zifencei
  target/riscv: rename ext_icsr to ext_zicsr
  target/riscv: rename ext_icbom to ext_zicbom
  target/riscv: rename ext_icboz to ext_zicboz

 hw/riscv/boot.c                             |  2 +-
 hw/riscv/virt.c                             |  4 +-
 target/riscv/cpu.c                          | 56 ++++++++++-----------
 target/riscv/cpu_cfg.h                      |  8 +--
 target/riscv/csr.c                          |  2 +-
 target/riscv/gdbstub.c                      |  2 +-
 target/riscv/insn_trans/trans_rvi.c.inc     |  2 +-
 target/riscv/insn_trans/trans_rvzicbo.c.inc | 16 +++---
 target/riscv/kvm/kvm-cpu.c                  | 12 ++---
 target/riscv/tcg/tcg-cpu.c                  | 20 ++++----
 10 files changed, 62 insertions(+), 62 deletions(-)

-- 
2.41.0




reply via email to

[Prev in Thread] Current Thread [Next in Thread]