qemu-riscv
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 3/5] hw/s390x: Rename cpu_class_init() to include 'sclp'


From: Thomas Huth
Subject: Re: [PATCH 3/5] hw/s390x: Rename cpu_class_init() to include 'sclp'
Date: Thu, 11 Jan 2024 19:00:24 +0100
User-agent: Mozilla Thunderbird

On 11/01/2024 13.02, Philippe Mathieu-Daudé wrote:
cpu_class_init() is specific to s390x SCLP, so rename
it as sclp_cpu_class_init() (as other names in this file)
to ease navigating the code.

Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
---
  hw/s390x/sclpcpu.c | 4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/hw/s390x/sclpcpu.c b/hw/s390x/sclpcpu.c
index f2b1a4b037..fa79891f5a 100644
--- a/hw/s390x/sclpcpu.c
+++ b/hw/s390x/sclpcpu.c
@@ -73,7 +73,7 @@ static int read_event_data(SCLPEvent *event, 
EventBufferHeader *evt_buf_hdr,
      return 1;
  }
-static void cpu_class_init(ObjectClass *oc, void *data)
+static void sclp_cpu_class_init(ObjectClass *oc, void *data)
  {
      SCLPEventClass *k = SCLP_EVENT_CLASS(oc);
      DeviceClass *dc = DEVICE_CLASS(oc);
@@ -94,7 +94,7 @@ static const TypeInfo sclp_cpu_info = {
      .name          = TYPE_SCLP_CPU_HOTPLUG,
      .parent        = TYPE_SCLP_EVENT,
      .instance_size = sizeof(SCLPEvent),
-    .class_init    = cpu_class_init,
+    .class_init    = sclp_cpu_class_init,
      .class_size    = sizeof(SCLPEventClass),
  };

Reviewed-by: Thomas Huth <thuth@redhat.com>




reply via email to

[Prev in Thread] Current Thread [Next in Thread]