qemu-riscv
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 1/5] accel: Rename accel_init_ops_interfaces() to include 'sy


From: Alistair Francis
Subject: Re: [PATCH 1/5] accel: Rename accel_init_ops_interfaces() to include 'system'
Date: Fri, 12 Jan 2024 09:13:17 +1000

On Thu, Jan 11, 2024 at 10:05 PM Philippe Mathieu-Daudé
<philmd@linaro.org> wrote:
>
> accel_init_ops_interfaces() is system specific, so
> rename it as accel_system_init_ops_interfaces() to
> ease navigating the code.
>
> Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>

Reviewed-by: Alistair Francis <alistair.francis@wdc.com>

Alistair

> ---
>  accel/accel-system.h | 2 +-
>  accel/accel-system.c | 2 +-
>  accel/accel-target.c | 2 +-
>  3 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/accel/accel-system.h b/accel/accel-system.h
> index d41c62f21b..2d37c73c97 100644
> --- a/accel/accel-system.h
> +++ b/accel/accel-system.h
> @@ -10,6 +10,6 @@
>  #ifndef ACCEL_SYSTEM_H
>  #define ACCEL_SYSTEM_H
>
> -void accel_init_ops_interfaces(AccelClass *ac);
> +void accel_system_init_ops_interfaces(AccelClass *ac);
>
>  #endif /* ACCEL_SYSTEM_H */
> diff --git a/accel/accel-system.c b/accel/accel-system.c
> index fa8f43757c..f6c947dd82 100644
> --- a/accel/accel-system.c
> +++ b/accel/accel-system.c
> @@ -62,7 +62,7 @@ void accel_setup_post(MachineState *ms)
>  }
>
>  /* initialize the arch-independent accel operation interfaces */
> -void accel_init_ops_interfaces(AccelClass *ac)
> +void accel_system_init_ops_interfaces(AccelClass *ac)
>  {
>      const char *ac_name;
>      char *ops_name;
> diff --git a/accel/accel-target.c b/accel/accel-target.c
> index 7e3cbde5df..08626c00c2 100644
> --- a/accel/accel-target.c
> +++ b/accel/accel-target.c
> @@ -104,7 +104,7 @@ static void accel_init_cpu_interfaces(AccelClass *ac)
>  void accel_init_interfaces(AccelClass *ac)
>  {
>  #ifndef CONFIG_USER_ONLY
> -    accel_init_ops_interfaces(ac);
> +    accel_system_init_ops_interfaces(ac);
>  #endif /* !CONFIG_USER_ONLY */
>
>      accel_init_cpu_interfaces(ac);
> --
> 2.41.0
>
>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]