bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tail after tab completion in prompt


From: Linda Walsh
Subject: Re: tail after tab completion in prompt
Date: Sat, 06 May 2006 16:06:41 -0700
User-agent: Thunderbird 1.5.0.2 (Windows/20060308)

I don't understand the problem specification.

I tried duplicating the problem in 4 different terms:
SecureCRT->a linux box, then in three cygwin variations:
the Win-cmd style "terminal", rxvt (non-X version), and
rxvt (X-version).  They all appeared to look the same.

What is meant by typing "ls /usr/src" twice?

> "ls /usr/src; ls /usr/src" ?
or typing in "ls /usr/src" at two different prompts, one
after the other?

All I see is the colored prompt:
address@hidden <dir>]$
where dir=the last dir component (or "~" for home).




Eric Blake wrote:
Here is another case of a complaint about prompt display bugs when the
prompt occupies a single line and contains invisible characters.  I was
able to repeat the original poster's display bugs on cygwin when using
rxvt, bash 3.1.14, readline 5.1 compiled with multibyte support using the
ncurses 5.5 library.  I had to undo the line wraps from the PS1 in the
OP's email (use space instead of newline).

- -------- Original Message --------
Subject: tail after tab completion in prompt
Date: Thu, 30 Mar 2006 14:06:46 +0800
From: William Xue <william.xue AT gmail DOT com>
To: cygwin AT cygwin DOT com

Hi,
Please let me describe the issue for you:
After set the PS1 in .bashrc to :
- ---8<--------------------------------------------->8---
PS1="\[\e]2;\w  --  address@hidden@\H  hangsps:\j    \d
\t\a\]\[\e[31;1m\][\[\e[36;address@hidden
\[\e[33;1m\]\W\[\e[31;1m\]]\[\e[34;1m\]\[\e[32;1m\]\$ \[\e[37;1m\]"
- ---8<--------------------------------------------->8---

If type "ls /usr/src" twice, it will show "ls /usr/src/usr/src".

Is there something wrong in the PS1? And how can I fix this issue?




reply via email to

[Prev in Thread] Current Thread [Next in Thread]