[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Makefile problem

From: Nick Clifton
Subject: Re: Makefile problem
Date: Wed, 07 Jan 2004 14:59:13 +0000
User-agent: Gnus/5.1001 (Gnus v5.10.1) Emacs/21.3 (gnu/linux)

Hi Anlodd,

> I am trying to install binutils-2.14 on RedHat 9 with make 3.79.1
> and make install returns following error:
> make[2]: Leaving directory
> `/home/anlodd/work/src/binutils-build/libiberty/testsuite'
> /bin/sh ../../binutils-2.14/libiberty/../mkinstalldirs
> /var/tmp/binutils/usr/lib
> /bin/sh /install-sh -c -m 644 libiberty.a
> /var/tmp/binutils/usr/lib/libiberty.an
> /install-sh: /install-sh: No such file or directory
> make[1]: *** [install_to_libdir] Error 127
> make[1]: Leaving directory
> `/home/anlodd/work/src/binutils-build/libiberty'
> make: *** [install-libiberty] Error 2

Were there any errors reported when you ran configure in the libiberty
directory ?  In particular was there a message like this:

  configure: error: can not find install-sh or install.sh in <list of 

> I seems that variables s and r in Makefile is not assigned properly
> and not exported to sub-make's. I can not figure out why.

Where are these variables defined ?

> Command used:
> ./configure --enable-shared

Note - for gcc and binutils it is generally better to configure in a
directory other than the source directory.

> make
> make -e DESTDIR=/var/tmp/binutils install

The installation of binutils 2.14 under RH9 has worked for other
people, so I am hoping that there is something specific to your
installation that is causing these problems.

Have you tried using these sequence of commands instead ?

  cd <sources>
  mkdir ../build
  cd ../build
  ../<sources>/configure --enable-shared --prefix=/var/tmp/binutils
  make install



reply via email to

[Prev in Thread] Current Thread [Next in Thread]