[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help getting read-only access to the CVS source repository

From: Mark D. Baushke
Subject: Re: Help getting read-only access to the CVS source repository
Date: Fri, 10 Sep 2004 01:12:05 -0700

Hash: SHA1

Hi Shane,

Here is what I have used:

In one window use the command:

  ssh -L24010:localhost:2401 tunnel@cvshome.org

the password is 'tunnel', or you can pick up a copy of the private key
to use on the web site. This window will be left alone while you run
the cvs commands in another window. For what it is worth, I use 'screen'
to keep the forwarded connection safe... :-)

Now set your CVSROOT so that it uses the forwarded port 24010 on your
localhost machine:

  CVSROOT=:pserver:turner@localhost:24010/cvs; export CVSROOT

You may now do your cvs commands like

  cvs login
  cvs checkout ccvs

which will connect via port forwarding to the :pserver: running on
cvshome.org and work for you. If that does not work, let me know
privately and I'll try to get you a snapshot of the top-of-tree cvs.

        -- Mark

Shane Turner <turner@infointeractive.com> writes:

> I submitted a patch on September 2nd to give CVS the ability to
> resolve modules based on a user-supplied revision number, or tag. One
> of the comment from Mark Baushke was that patches are prefered to be
> based on the top of the tree for cvshome.org. I agree. However I
> believe that I've registered properly on www.cvshome.org, but the
> account is in a workable state (unable to view any pages once logged
> in). I've tried following what instructions that I could find to
> attempt using 'cvs login' but I've had no luck so far. What I've tried
> is:
> export CVSROOT=:pserver:turner@cvs.cvshome.org/cvsroot
> cvs login
> In response I'm getting '/cvsroot: no such repository'.
> Is the problem the CVSROOT that I'm using? If it's not I'll try
> setting up another account on www.cvshome.org.
> Any help would be appreciated. I'd love to make some improvements to
> the 'versioned modules' patch, but based on the current source tree.
> Thanks,
> Shane Turner
> PS: I've been unable to make any contact with anyone about
> www.cvshome.org. The only way I can find any email address at all is
> by logging into my broken account and viewing a page that leads to an
> error (all pages). I've mailed webmaster@cvshome.org twice now (more
> than a month apart) with no response. It's very frustrating.
Version: GnuPG v1.2.3 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]