[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compile error on HP

From: Mark D. Baushke
Subject: Re: Compile error on HP
Date: Tue, 08 Nov 2005 08:59:39 -0800

Hash: SHA1

stealthsurfer@gmail.com <stealthsurfer@gmail.com> writes:

> I have been trying to compile cvs 1.12.13 on 2 different HP systems.
> One is an 11.00 box with gcc and the other is 11.11 with a HP compiler.
> On both I get the same error on the make:
> SUDO>guk46s01-$ make
> No suffix list.
>         make  all-recursive
> No suffix list.
> Making all in lib
>         /bin/sh ../build-aux/ylwrap getdate.y y.tab.c getdate.c y.tab.h
> getdate.h y.output getdate.output -- /bin/sh
> /home/gussodeo/cvs-1.12.13/build-aux/bison-missing --run bison -y
> /bin/sh: /home/gussodeo/cvs-1.12.13/build-aux/bison-missing:  not
> found.
> *** Error exit code 1
> Stop.
> *** Error exit code 1
> Stop.
> *** Error exit code 1
> Stop.
> I didnt understand the problem with gcc but seeing the same error with
> a native compiler on a different system confuses me even more.

I am not sure which version of make you are using or why it is having
problems with a suffix list.

However, the bison generated files should not be needed unless you have
configured using --enable-maintainer-mode.

A workaround might be

  touch lib/getdate.c lib/getdate.h

so that they will both be newer than lib/getdate.y

You may wish to do the following:


and look closely at the output to see what is happening. 

If the HP/UX version of make does not work, then you could pick up a
copy of GNU make http://hpux.cs.utah.edu/hppd/hpux/Gnu/make-3.80/
and give that a try.

        -- Mark
Version: GnuPG v1.2.3 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]