[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: new module 'popcount'

From: Ben Pfaff
Subject: Re: new module 'popcount'
Date: Tue, 24 Jul 2007 20:14:21 -0700
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.1 (gnu/linux)

Ben Pfaff <address@hidden> writes:

> It seems that many people do not like the name 'popcount'.
> How about the name 'count_one_bits'?  It is a little longer, but
> it should be possible for many people to guess what it does
> without resorting to jargon.

Having received one private vote in favor, and none against, I
checked in this change.  The patch is not interesting, but here
is the ChangeLog entry:

2007-07-24  Ben Pfaff  <address@hidden>

        Improve name: "count-one-bits" is better than "popcount".
        * MODULES.html.sh: Update name.
        * lib/popcount.h: Renamed lib/count-one-bits.h.
        (popcount): Renamed count_one_bits.
        (popcountl): Renamed count_one_bits_l.
        (popcountll): Renamed count_one_bits_ll.
        * m4/popcount.m4: Renamed m4/count-one-bits.m4.
        * modules/popcount: Renamed module/count-one-bits.
        * modules/popcount-tests: Renamed module/count-one-bits-tests.
        * tests/test-popcount.c: Renamed tests/test-count-one-bits.c.
Ben Pfaff 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]