[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Please, help on Grub

From: Giovanni Benedetti
Subject: Please, help on Grub
Date: Tue, 07 Nov 2000 19:27:03 +0100

Dear Sirs,

    sorry to bother you. I tried all my best for not disturbing you but,
really, I don't know where to get a solution by myself anymore.
If you could be so kind to help me, I would really appreciate.

My job is to develop Web sites and to configure NT/Linux servers for
Internet, therefore I have to test my applications on several operating
systems/distributions. For that, I'm using an IDE disk of 40GB, sliced
in several different partitions. I know that's a crazy way of dueing,
but please consider I often just need to test if a configuration is
working or not on a particular system and nothing more, and to switch
on/off all the time a bunch of disks is very boaring.
My problem is that I can't load BeOS 4.5 using Grub.
My IDE disk is sliced as following:
    /dev/hda1    Windows 98
    /dev/hda2    /boot
    /dev/hda3    swap
    /dev/hda4    extended
    /dev/hda5    (data only) FAT32 filesystem
    /dev/hda6    BeOS 4.5
    /dev/hda7    Windows NT 4.0 Server
    /dev/hda8    Caldera 2.3
    /dev/hda9    SuSE 6.4
    /dev/hda10  Debian 2.2
    /dev/hda11  Mandrake 7.0
    /dev/hda12  Slackware 7.0
    /dev/hda13  Mandrake 7.1
    /dev/hda14  Corel Linux 1.0
    /dev/hda15  Linux Espresso 0.2
    /dev/hda16  Turbolinux 6.0
    /dev/hda17  easyLinux 2.2
    /dev/hda18  FreeBSD 3.3
    /dev/hda19  NetBSD 1.4
    /dev/hda20  SCO Unixware 7.1
    /dev/hda21  Red Hat 6.2
    /dev/hda22  Windows 2000 Server
I was using LILO as boot loader, in the past.
Recently, I installed Mandrake 7.1 which allow to use Grub 0.5.94 as
boot loader. I tried it and I found it really powerful and flexible.
Everything worked fine and all the operating systems loads in a
wonderful way by the Grub menu. Everyone except BeOS.
I have to use that experimental operating system because I have one of
my better customer who like it and pretend to use it in his company, and
want me to prepare an Intranet which works on it.
I can still access to the BeOS partition just booting the system by the
BeOS boot floppy, but I would like to use Grub.
Dueing the fact I think it's possible, it means I have been not able to
properly set up Grub for that.
When I was using LILO I was able to access the BeOS partition after a
modification of the lilo.conf file, where I added the following lines:
    other = /dev/hda6
    label = beos
    table = /dev/hda
This because BeOS has it's own boot loader, called Bootman, which can be
installed on the MBR only.
I configured the entry for BeOS in the menu.lst file of Grub as
    root (hda0,5)
    chainloader +1
but, as I told you, it doesn't works.
When I try to launch BeOS from the Grub menu, it prints the following
error message:
    root (hd0,5)
        Filesystem type unknown, partition type 0xeb
    Error: no such partition
I also tried the chainloader --force +1 command, but it doesn't works
If I well understood, the +1 option means that will be chainloaded the
first sector in the particular partition. That's could be the problem I
supposed, because BeOS Bootman program doesn't allow to install the
loader in the first sector of the partition but only in the MBR.
With the table= option in lilo.conf  I solved the problem in the past,
but I couldn't recognize a corrispondent command in Grub. Surely it
exists. That's my question: which the command is?

Thank you in advance and really really SORRY for disturbing you about
this matter.
I searched a solution on usenet, but it looks like nobody is so stupid
like me trying to use a such complex configuration. Nobody has an answer
for me.
If you have no time for helping me, please just let me know where the
solution could be.

Thank you again

Yours sincerely

Giovanni Benedetti
Florence - Italy

reply via email to

[Prev in Thread] Current Thread [Next in Thread]