[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[grub #46] GUI not visible

From: deger
Subject: [grub #46] GUI not visible
Date: Sat, 08 Feb 2003 02:35:25 +0900

Reporter: address@hidden
Summary: GUI not visible
Version: 0.92
Type: software bug

-------------Operating Environment ---------------------
OS: Dual boot W2k/RH Linux 8 kernel 2.4.18-24.8.0.athlon
NVIDIA_kernel-1.0-4180 and NVIDIA_GLX-1.0-4180 is compiled into the kernel 
using source distribution (tgz), if this helps to diagnose the problem.

-------------Hardware Environment --------------------
CPU: AMD Athlon 900MHz
MB: MSI MS-6380
Graphics Card: NVidia TNT2 M64 TV-out based Creative
HD: Western Digital 20Gig.
plus the usual peripherals

------------- Problem Description -------------------
Grub 0.92 is native to the OS (RedHat Linux 8) and used to chainload W2K and 
boot RH. I had 'the blue screen of death' problems when chainloading W2K so I 
thought of hiding (hd0,1). At first, I did not realise that booting Win NT was 
described in the documentation under Configuration, I was expecting to find it 
under Booting->OS-scpecific notes->DOS/Windows. (IMHO there should be a 
note/pointer under Booting->OS-scpecific notes->DOS/Windows to Configuration) 
So I initially changed menu.lst to include: 
title Windows 2000
    unhide (hd0,0) #where W2K is installed
    hide (hd0,1) #where RHL is installed
    root (hd0,0)
    chainloader +1

Initially this worked fine for a few times, although I got the blue screen once 
or twice, out of, say 10. This was tolerable. Meanwhile, auto-adjustment 
feature of my monitor was having trouble adjusting/focusing Grub GUI. Then, 
Grub GUI dissapeared, falling back to text mode. I could still write the above 
commands and chainload W2K but it was tedious and I had to use a boot disk to 
start RHL, because I could not remember the commands and image names, etc. I 
thought to myself: "Hmm, if I reinstall Grub onto MBR and this problem will 
probably go away" (What a prat, eh) 

When I tried "find /boot/grub/stage1" in "hd0,1" through to "hd0,4" nothing 
came up. It seemed the command was always looking at floppy device, no matter 
what I wrote (I could hear and see the light flash on floppy drive). Hence, I 
could not reinstall Grub. In the mean time, I came accross how to boot WinNT in 
the documentation and grafted/replaced the boot method (see below for the 
pasted 'grub.conf') Then Grub GUI reappeared automagically, hoorah! 

The conclusion I got from this is that when a partition is hidden using 'hide' 
command it stays hidden to Grub even after W2K is shut down or rebooted, thus 
making Grub unable to read grub.conf from (hd0,1) and not being able to 
reproduce its GUI, or something like this. I hope this makes sense and helps 
splat the bug. If it sounds silly, blame it on me.

PS. Thanks for producing such a wonderful utility, if I may call it. Without 
you I wouldn't be able to discover the wonderful world of Linux, probably ;)

--------------- Present grub.conf -------------------------
# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,1)
#          kernel /vmlinuz-version ro root=/dev/hda3
#          initrd /initrd-version.img
password --md5 ************************
title Red Hat Linux (2.4.18-24.8.0debug)
        root (hd0,1)
        kernel /vmlinuz-2.4.18-24.8.0debug ro root=LABEL=/
        initrd /initrd-2.4.18-24.8.0debug.img
title Red Hat Linux (2.4.18-24.8.0)
        root (hd0,1)
        kernel /vmlinuz-2.4.18-24.8.0 ro root=LABEL=/
        initrd /initrd-2.4.18-24.8.0.img
title Red Hat Linux (2.4.18-18.8.0debug)
        root (hd0,1)
        kernel /vmlinuz-2.4.18-18.8.0debug ro root=LABEL=/
        initrd /initrd-2.4.18-18.8.0debug.img
title Red Hat Linux (2.4.18-18.8.0)
        root (hd0,1)
        kernel /vmlinuz-2.4.18-18.8.0 ro root=LABEL=/
        initrd /initrd-2.4.18-18.8.0.img
title Red Hat Linux (2.4.18-14)
        root (hd0,1)
        kernel /vmlinuz-2.4.18-14 ro root=LABEL=/
        initrd /initrd-2.4.18-14.img
title Windows 2000
        root (hd0,0)
        chainloader +1

Please send followups to <address@hidden>.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]