[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ufs2 - troubles

From: Robert Millan
Subject: Re: ufs2 - troubles
Date: Fri, 10 Oct 2003 10:46:43 +0000
User-agent: Mutt/1.5.4i

On Fri, Oct 10, 2003 at 04:32:56AM +0400, Sergey Matveychuk wrote:
> And finally I can't to debug grub with grub-shell. When I ran it and 
> type 'root (hd0)' I got an error:
> Error 21: Selected disk does not exist

GRUB shell is unable to access FreeBSD 5.x's kernel devices currently. The
first problem is it uses old device names ("rad0") and can be easily solved,
see my patch [1].

The second problem is FreeBSD's kernel now stablishes a special protocol for
obtaining raw read/write access to the hard disk, which GRUB is hasn't been
taught to deal with yet. See the discussion [2].

I suggest you use GNU/Linux (if you have it at hand) for your tests, you should
be able to access UFS2 filesystems from the GRUB shell then.

[1] http://mail.gnu.org/archive/html/bug-grub/2003-07/msg00067.html
    (This patch is waiting for my copyright papers to be applied.)
[2] http://mail.gnu.org/archive/html/bug-grub/2003-06/msg00012.html

Robert Millan

"[..] but the delight and pride of Aule is in the deed of making, and in the
thing made, and neither in possession nor in his own mastery; wherefore he
gives and hoards not, and is free from care, passing ever on to some new work."

 -- J.R.R.T, Ainulindale (Silmarillion)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]