[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem booting into that other OS using grub

From: Nicolas Mailhot
Subject: Problem booting into that other OS using grub
Date: Sat, 29 May 2004 21:46:53 +0200


        Some time ago (around march) I had a hardware problem (basically me not
being careful enough during component replacement) that corrupted data
on all my hard drives.

        As a result I reinstalled from scratch my linux system. Today I decided
to reinstall the other OS that lives on an old 12 GiB disk (comes handy
every few months to check a oo.o pdf can be read by acrobat reader). To
simplify things I went in the bios, put the drive in lba mode, told the
bios to boot from it, scratched all existing partitions and let the OS
create a new partition spanning all the drive. So far so good.

        After loosing massive amounts of time getting everything to a current
patchlevel I told the bios to resume booting on the "SCSI" card (the
additional ide card on which the linux raid is). It booted in grub all
right, and I selected other OS in the menu (I had restored my pre-crash
grub.conf by then). Black screen, no activity.

        The grub entry is a simple :

title Other
        map (hd2) (hd0)
        rootnoverify (hd2,0)
        chainloader +1

(and I think the map part is largely irrelevant since the latest version
of the other OS enumerates disks like linux and grub now)

I've tried to change the grub entry a little without getting anything
but a hang (sometimes the grub commands stays displayed, 
sometimes the screen is blank). I've tried with FC1 and FC2 versions of
grub. I'm stuck.

So I'm suspecting there is a partitionning problem now.

Fdisk says :

The number of cylinders for this disk is set to 1650.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Disk /dev/hde: 13.5 GB, 13578485760 bytes
255 heads, 63 sectors/track, 1650 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
   Device Boot      Start         End      Blocks   Id  System
/dev/hde1   *           1        1649    13245561    7  HPFS/NTFS

Parted says :

Using /dev/hde
Warning: Unable to align partition properly.  This probably means that
partitioning tool generated an incorrect partition table, because it
didn't havethe correct BIOS geometry.  It is safe to ignore,but ignoring
may cause
(fixable) problems with some boot loaders.
Ignore/Cancel? i
(parted) p
Disk geometry for /dev/hde: 0.000-12949.453 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031  12935.148  primary   ntfs        boot

What I'm interested is the fixable part of the parted message. Both the
Linux and the other OS installations are sane, changing the boot order
in the bios always work. It's not too practical however (going into the
bios for this is a great way to nuke a system by fooling with other
options). So I'd like to get grub working as it used to.

Am I doing an obvious mistake ?

Is this a grub bug ? Should it be bugzillaed ?

Nicolas Mailhot

Attachment: signature.asc
Description: Ceci est une partie de message numériquement signée

reply via email to

[Prev in Thread] Current Thread [Next in Thread]