[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

No output from stage1

From: Greg Ward
Subject: No output from stage1
Date: Wed, 1 Sep 2004 14:49:34 -0400
User-agent: Mutt/1.4.1i

Hi -- I'm trying to reinstall GRUB onto my hard drive after
repartitioning it.  I've been running Red Hat Linux 9 with GRUB 0.93
absolutely perfectly for about a year.

Unfortunately, booting now completely fails with zero output; I don't
see "GRUB" or any error message on the screen.  The machine is just
dead.  Luckily, I can boot from a floppy with stage1 and stage2 on it,
so I'm not completely screwed.

Here's the scenario: I've just repartitioned my drive into hda1 (swap)
and hda2 (one big 75 GB ReiserFS):

Disk /dev/hda: 9729 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0
   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/hda1          0+    511     512-   4112608+  82  Linux swap
/dev/hda2   *    512    9728    9217   74035552+  83  Linux
/dev/hda3          0       -       0          0    0  Empty
/dev/hda4          0       -       0          0    0  Empty

To install GRUB natively, I prepared a GRUB floppy as described in the
manual, namely

  dd if=stage1 of=/dev/fd0 bs=512 count=1
  dd if=stage2 of=/dev/fd0 bs=512 seek=1

and rebooted.  In the native GRUB session I ran

  root (hd0,1)    # aka /dev/hda2
  setup (hd0)

GRUB printed several lines of output which I don't have handy, since
it's hard to cut and paste out of a native GRUB session.  ;-(  Anyways,
it looked very much as though GRUB was installing itself onto /dev/hda
(hd0) using the reiserfs_stage1_5 file in (hd0,1)/boot/grub.

But then when I boot of my hard drive, as I said, I get nothing at all.
The only way I can boot is using my GRUB floppy, which runs stage1 and
stage2 fine and then boots the kernel in (hd0,1)/boot/vmlinuz.  If I run
"dd if=/dev/hda bs=512 count=1 | od -c" it sure looks like there's a GRUB
stage1 there -- it's not identical to /boot/grub/stage1, but isn't that
because there are block lists encoded in the MBR version of stage1?
Anyways, I see strings like "GRUB" and "Read Error" in there, so it's
not random gibberish.

I don't see anything in the manual about how to troubleshoot this
situation.  Any clues?  Thanks --


reply via email to

[Prev in Thread] Current Thread [Next in Thread]