[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub hangs on initrd

From: Lux
Subject: grub hangs on initrd
Date: Thu, 18 Aug 2005 21:03:02 +0200

Hi all.

I have a P4 PC with an adaptec 2120 raid controller, with a RAID5 volume
made of 3 scsi disks. Fedora Core 3 GNU/Linux on it.
One day a disk failed. It was replaced and the controller reconstructed the
raid volume correctly (at least for what it seems).
But when I reboot the system, grub hangs at the initrd command, withount any
error messages.
If I try to boot grub in console (shell-like) mode and give the commands to
grub manually, I obtain:

grub> root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83

grub> kernel /vmlinuz-2.6
 [Linux-bzImage, setup=0x1400, size=0x14d2a0]

grub> initrd /initrd-2.6.img
 [linux-initrd @ 0x5deda000, 0x115acf bytes]


And here Grub is frozen. Note the last grub prompt: it seems that the initrd
command is performed, but I cannot give any further command (I would only
like to issue "boot"!!)

Things I tried:
several different kernels, both from the distro and compiled by me, both smp
and up;
different grub versions: 0.95.3 from Fedora, on hard disk and on floppy.
0.97 from the file grub-0.97-i386-pc.tar.gz I downloaded via ftp from the
Grub site;
reinstalled grub both via grub-install and via the grub shell-like
fsck-ed all the file systems, which gave no errors;
when Grub hangs, I can not issue ctrl-alt-del: the system seems to be really
installed LILO, it boots without problems. After that, reinstalled Grub, and
it still hangs on initrd.
I tried the debug command in grub, but it gives me no additional output.

I would like to investigate what the Grub problem can be, but have no clue
about it.

Thank you in advance.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]