[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GRUB1 on USB-Stick

From: Christoph Anton Mitterer
Subject: GRUB1 on USB-Stick
Date: Thu, 31 Jan 2008 11:06:33 +0100


I've just tried to install grub1 on an USB-stick in order to boot from
it, but it continues to fail:

Following situation:
-BIOS is definitely able to boot from USB
-the system has one harddisk /dev/sda
-USB-stick has one partition /dev/sdb1, type 0x83, filesystem ext3
-Debian sid => grub 0.97
-Installation of grub on /dev/sda works with both grub-install and the
grub shell

The stick is mounted on /mnt/
-/boot/grub/device.map shows:
(hd0) /dev/sda
This is also automatically generated by grub-install --recheck /dev/sda

-/mnt/boot/grub/device.map shows:
(fd0) /dev/fd0
(hd0) /dev/sda
(hd1) /dev/sdb
Automatically generated, too (via grub-install --recheck
--root-directory=/mnt /dev/sdb)
btw: this is strange, because the notebook doesn't have an floppy dr

I really tried every combination I could think of: Via grub-install,
grub-shell, with and without device.map, with hd0 and hd1, from a chroot
and not, etc. etc.

Some of them look like the following:

via grub-install:
# grub-install --recheck --root-directory /mnt /dev/sdb
Probing devices to guess BIOS drives. This may take a long time.
The file /mnt/boot/grub/stage1 not read correctly.


via grub-install:
# grub-install --root-directory /mnt /dev/sdb
The file /mnt/boot/grub/stage1 not read correctly.

via grub shell:
grub> device (hd0) /dev/sdb
grub> root (hd0,0)
FIlesystem type is ext2fs. partition type 0x83
grub> setup (hd0)
setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... no

Error 2: Bad file or directory type

>From chroot into /mnt/
grub-install --recheck --root-directory /mnt /dev/sdb (with and without
--recheck) seems to work,.. at least grub-install reports no error,

When I now boot from the stick (it actually seems to use the grub on the
stick, and not that on the HDD, because it "works" even, when I
deactivate the HDD in the BIOS) grub loads,... but it uses the menu.lst
from the hdd (/dev/sda) and not from the stick. (I can see this because
I've renamed the entries).

Perhaps you have some ideas :-)

Note, that switching to grub2 is not really an option for me,... on
reason are still missing features in grub2 like password protection.

Best wishes,

btw: Please CC me, as I'm currently not subscribed.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]