[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #52387] grub rescue not finding gpt partitions

From: Thomas Schweikle
Subject: [bug #52387] grub rescue not finding gpt partitions
Date: Fri, 10 Nov 2017 09:30:20 -0500 (EST)
User-agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.102 Safari/537.36 Vivaldi/1.93.955.48


                 Summary: grub rescue not finding gpt partitions
                 Project: GNU GRUB
            Submitted by: tps800
            Submitted on: Fri 10 Nov 2017 02:30:19 PM UTC
                Category: None
                Severity: Major
                Priority: 5 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 2.02
         Reproducibility: Every Time
         Planned Release: None



Grub 0.96 installed on hd0, partition 3, /grub.
Grub 2.02 installed in /helenos/32/grub on hd0, partition 2.

In grub1 /grub/grub.conf:
title HelenOS
  root (hd0,2)
  kernel /helenos/32/grub/i386-pc/core.img

Selecting this entry while booting loads core.img:

Welcome to GRUB!

error: no such partition
Entering rescue mode ...
grub rescue>

Trying to list partitions:
grub rescue>ls
(hd0) (hd1) (fd0)

grub2 does not list any partitions!
consequently all found tutorials working with grub-rescue-mode fail:
grub rescue> set prefix=(hd0,2)/helenos/32/grub
grub rescue> set root=(hd0,2)
grub rescue> insmod normal
error: no such partition.

At this point you are lost. Since grub dos not find partitions (I could test
msdos and gpt both behave the same). It can not load any modules. I've tried:

to install grub2 using "grub-install /dev/sda2", then chainloading from
> root (hd0,2)
> chainloader +1
> boot

same as before. Grub2 tells me "no such partition". I've even tried to put
grub into (hd0,2)/grub. But again without success. Same error again.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]