[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #52440] Invalid OpenBOOT path for a device

From: Mathieu Malaterre
Subject: [bug #52440] Invalid OpenBOOT path for a device
Date: Sat, 18 Nov 2017 12:22:52 -0500 (EST)
User-agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.89 Safari/537.36


                 Summary: Invalid OpenBOOT path for a device
                 Project: GNU GRUB
            Submitted by: malat
            Submitted on: Sat 18 Nov 2017 05:22:51 PM UTC
                Category: Filesystem
                Severity: Major
                Priority: 5 - Normal
              Item Group: Hardware-specific
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 2.02
         Reproducibility: Every Time
         Planned Release: None



Yaboot ofpath is currently the only
device-node-to-OF-path-translation-tool that worked "correctly" for
the tested G5 Power Macs.

E.g. when devalias in OF says it's 

We get for /dev/sda2:

* grub-ofpathname returned
"/address@hidden,f2000000/address@hidden/address@hidden/address@hidden:b" which 
didn't work


* ofpath returned 
"/address@hidden,f2000000/address@hidden/address@hidden/@0/@0:2" which worked


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]