[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: grub make error

From: Chen, Farrah
Subject: RE: grub make error
Date: Tue, 19 Mar 2019 01:21:02 +0000

Thank you for your advice, but I think my environment has met the minimal build requirements.
And I tried again, there’s no issue with commit: f8f35acb5b05d40e3707a9d2db9ede60023e4cac, this error just happened from 35b909062e7b334eb4af372be3260d0f62d85375.
Info in INSTALL:
If you use a development snapshot or want to hack on GRUB you may
need the following.
* Python 2.6 or later
* Autoconf 2.63 or later
* Automake 1.11 or later
* GCC 4.1.3 or later
  Note: older versions may work but support is limited
My environment:
./configure --version
GRUB configure 2.03
generated by GNU Autoconf 2.69
yum info automake
Name        : automake
Arch        : noarch
Version     : 1.13.4
Release     : 3.el7
Size        : 1.7 M
Repo        : installed
python --version
Python 2.7.5
gcc --version
gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-36)
-----Original Message-----
From: Daniel Kiper [mailto:address@hidden]
Sent: Tuesday, March 19, 2019 5:22 AM
To: Chen, Farrah <address@hidden>
Cc: Colin Watson <address@hidden>; address@hidden; Hao, Xudong <address@hidden>
Subject: Re: grub make error
On Mon, Mar 18, 2019 at 02:53:10PM +0000, Chen, Farrah wrote:
> Sorry, I attached wrong log just now, if you received the email, please ignore.
> Yes, I am using git://git.savannah.gnu.org/grub.
> I attached all the log, can you help to check? It's strange, before this commit, I never met such error.
> Do I need to update or install any other tools?
> And my OS is " Red Hat Enterprise Linux Server release 7.6 (Maipo)", actually, I tried it on two different machines with Red Hat, all failed.
> Thanks a lot!
I am afraid that this happens due to old version of Autoconf and/or Automake. Please take a look at INSTALL file to get info about the minimal build requirements.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]