[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #19439] ``Kernel page fault at address 0x1d'' in `setup_rw_floppy',

From: Thomas Schwinge
Subject: [bug #19439] ``Kernel page fault at address 0x1d'' in `setup_rw_floppy', `linux/dev/drivers/block/floppy.c:1447'
Date: Wed, 28 Mar 2007 12:51:56 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20061201 Firefox/ (Ubuntu-feisty)


                 Summary: ``Kernel page fault at address 0x1d'' in
`setup_rw_floppy', `linux/dev/drivers/block/floppy.c:1447'
                 Project: The GNU Hurd
            Submitted by: tschwinge
            Submitted on: Wednesday 03/28/07 at 14:51
                Category: GNU Mach
                Severity: 3 - Normal
                Priority: None
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
         Reproducibility: Once
              Size (loc): None
         Planned Release: None
                  Effort: 0.00
Wiki-like text discussion box: 



I was running a Hurd system with an up-to-date GNU Mach kernel in QEMU and
was issueing a ``settrans -ca /tmp/f ./ext2fs-pre_ogi.static /dev/fd0'' when
I was presented with a system crash and the kernel debugger displaying a
``Kernel page fault at address 0x1d''.  Analyzing the eip showed that it
happened in `setup_rw_floppy', `linux/dev/drivers/block/floppy.c:1447'.

`ext2fs-pre_ogi.static' is -- as the name suggests -- a statically compiled
pre-Ogi-patched `ext2fs' (that allows block sizes different from 4k), has
worked before just fine and can be gotten from

`/dev/fd0' is a QEMU-emulated floppy disk device, operating on a GRUB disk
image.  When I earlier used `dd' to copy the whole device's content into a
file, that worked just fine.

(gdb) x/3i 0x16a6b5
0x16a6b5 <setup_rw_floppy+437>: movzbl 0x1d(%edx),%eax
0x16a6b9 <setup_rw_floppy+441>: cmp    %ebx,%eax
0x16a6bb <setup_rw_floppy+443>: jg     0x16a6a0 <setup_rw_floppy+416>

That's also what the kernel debugger showed me.

Examining the registers I see that %edx in fact is zero.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]