[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: My failure to install Hurd on Debian GNU/Linux kvm

From: Svante Signell
Subject: Re: My failure to install Hurd on Debian GNU/Linux kvm
Date: Sat, 20 Aug 2011 15:32:56 +0200

On Sat, 2011-08-20 at 15:11 +0200, Thomas Schmitt wrote:
> Hi,
> I Samuel Thibault's thread 'cdrom interface?' i wrote:
> > > Well, i am a bit embarassed that i failed to get Debian/Hurd running
> > > on qemu-kvm of a Debian/Linux squeeze. It installs but then does not
> > > boot. Other things kept me from re-trying and then asking for help.
> Samuel Thibault wrote:
> > Don't hesitate to ask. I'm running it completely fine in qemu-kvm in
> > wheezy.
> Ok, here is my mail sketch of end of june 2011. I have been distracted
> from this topic since then. But at least i now verified that kvm still
> starts from the Hurd "disk" into a GRUB prompt. (Over X and ssh from the
> headless Debian GNU/Linux to my workstation. My todo list says that i
> shall look for a non-graphical mode where i can copy+paste and need no X.)
> =======================================================================
> 29 June 2011:
> I have a freshly installed Debian GNU/Linux 6.0.2 on amd64.
> Now i try to install Hurd according to
>   http://people.debian.org/~sthibault/hurd-i386/installer/cdimage/README.txt
> -----------------------------------------------------------------------
> $ kvm-img create hurd-install.qemu 3G
> Formatting 'hurd-install.qemu', fmt=raw size=3221225472 
> $ kvm -m 512 -net nic,model=ne2k_pci -net user -no-kvm-irqchip -hda 
> hurd-install.qemu -cdrom netinst.iso -boot d
> $
> -----------------------------------------------------------------------
> I have chosen to use the entire "disk".
> This worked so far (except minor problems) until the install software
> urges me to remove the CD and to boot.
> Well, i do not know how to remove the virtual CD. So the reboot ends
> up in the first installer menu.
> This menu has an option to boot from the first disk.
> I did, but this only yields a GRUB prompt.
> Very strangely, next day, after rebooting the hosting GNU/Linux, i get from
>   $ kvm -m 512 -net nic,model=ne2k_pci -net user -hda hurd-install.qemu 
> -no-kvirqchip
>   kvm: invalid option -- '-no-kvirqchip'

I think you have a typo here: --no-kvm-irqchip, see above.

> I can still see the successful kvm runs of yesterday with that option
> (SSH session from not rebooted workstation).
> This was the first reboot after  apt-get install qemu-kvm .
> Without that option i get to the GRUB prompt again.

Maybe you are hit by the grub bug not recognizing the kvm disk for
certain sizes. Can you try with for example a 4GB image?

> >From the description i understand that it is not really needed
> for the installed Linux kernel:
>   $ uname -a
>   Linux debian2 2.6.32-5-amd64 #1 SMP Tue Jun 14 09:42:28 UTC 2011 x86_64 
> GNU/Linux

No you don't need that option unless you use kernels 2.6.33+ to 2.6.38.
In 2.6.39+ it is not needed any longer.

> The virtual hard disk now has this layout:
> Any idea how to get a running system ?

Don't you get a running system by choosing boot from the HDD in grub?

> Minor problems:
> The installation instructions propose to run kvm as normal user.
> On the freshly installed Debian 6.0.2, the permissions of /dev/kvm
> do not allow this. One ends up without hardware virtualiziation,
> which is indeed very slow.
> $ kvm -m 512 -net nic,model=ne2k_pci -net user -no-kvm-irqchip -hda 
> hurd-install.qemu -cdrom netinst.iso -boot d
> open /dev/kvm: Permission denied
> Could not initialize KVM, will disable KVM support

> I solved this by adding my normal user id to group kvm.

Yes, you need to be a member of the kvm group.

> Then i aborted the install run, deleted the disk image and started
> installation from scratch. (I.e. by kvm-img create hurd-install.qemu 3G)
> -----------------------------------------------------------------------
> The install process gave me no opportunity to enter the prescibed
> network paramters. (IP address: , ...)
> Is this a bad sign ?

The network is set up by dhcp, so this should be automatic by now.

> Have a nice day :)

You too!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]